Support » Fixing WordPress » Remove (edit) in Library?

  • In my list of Links, the word (Edit) appears after each link. I think it used to only be there for myself, the Administrator, but now everyone sees it. If my Users click on (Edit), thinking they are clicking on the link, it takes them to a page saying they do not have permission for this. As my Users are not very computer-literate, it is causing quite a bit of confusion. Is this new and is there a way to hide it from them?

    thanks,

    LLM

Viewing 10 replies - 1 through 10 (of 10 total)
  • What is your site? Have you checked that the edit links still show up if you log out of the admin?

    A quick fix would be to turn off the “Show edit links when logged in as editor or administrator” option.

    Sorry, maybe I wasn’t clear. I like having the Edit links there if I log in as the Admin. I do not want them there for the rest of the members; it’s confusing for them. They are not listed as Editors nor Administrators. When they click on the word ‘Edit’, they get an error message saying they do not have permission for that.

    I am not having any luck reproducing this problem. What is the address on your web site where this problem is happening?

    It is a private site so I will have to issue you a password. Can you send me your email address off list? thanks,

    Lin

    So every user gets a login to go to your site. Are you using some kind of user management plugin on your site? Are you giving users the ability to edit links in the back-end? I am looking to see if the user logged in has permissions to manage links before display the edit link.

    Yes, I use ‘Registered Users Only’. I also use ‘Role Scoper’ to break it down even further.

    None of my Users have permission to manage links; they are fairly unsophisticated users.

    My site has been up and operational since January of this year and both your plugin and Registered Users has been in place since the beginning. I added Role Scoper in mid-March.

    I don’t know exactly when this problem started but it was reported to me about 5 weeks ago. After I actually saw it on the User’s computer, I tried with a test account that I have that has no permissions — same thing — I saw the (Edit) flag where I never had before,

    Lin

    Interesting! I just removed the Role Scoper ‘Roles’ from my Test persona and the problem went away! OK, so now I know the cause and should be able to track it down,

    Lin

    Well, I was finally able to solve the problem! I turned off the group’s ability to edit links (even though they really couldn’t) in Role Scoper and the (Edit) went away for everyone except me, which is what I was looking for!

    Hi Lin,

    Thanks for documenting your experimentations here. I’ve dealt with Role Scoper before on another user’s site and did see some strange behaviours on there as well. I knew that the edit capabilities were working fine on my clean install so something else had to be at play.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Remove (edit) in Library?’ is closed to new replies.