WordPress.org

Support

Support » Plugins and Hacks » [Resolved] remove custom field data from the excerpt

[Resolved] remove custom field data from the excerpt

  • Hi,
    dose anyone know how to remove the custom field data from the excerpt?

    I want to separate the custom field out from the main excerpt so I can css it. Now it shows 2 copies of them, one in the excerpt which is styled like all other excerpt texts, one is at the bottom which I want to keep.

    I am using the below code
    Location: <?php echo get_post_meta( $post->ID, 'Location', true); ?>

    Thanks everyone

    http://wordpress.org/extend/plugins/wp-user-frontend/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Tareq Hasan
    Participant

    @tareq1988

    I am surprised to see that nobody takes a look to the plugin option. I said the same thing over and over in the support forum. Please take a look at the plugin options, there is checkbox there if you want to show attachments and custom fields in the post or not.

    The.MacGuffin
    Member

    @themacguffin

    I have the same problem and question. Tarek, I think you have misunderstood. I want to show custom fields in the add/edit pages BUT I dont want the custom field data to be added to the post content or exerpt.

    At the moment the custom field data is appended at the end of the post as if part of the post content. There is no checkbox in options asking if custom field data should be appended to post content.

    I have a custom field called Subitle. I add the custom field. I enter a value and post. Then on the post it shows the field data as list below post body. It is in my exerpt but perhaps because short test posts. I look at the post in Dashoboard and the field data not shown in my custom field.

    I have this question as well

    Aventador
    Participant

    @strangerrj

    Tareq has already said. It leaves itself and turn off in the settings. Can not be overlooked. If you want to display the custom fields individually, you can switch this off in the settings and eg its own code. <? php echo get_post_meta ($ post-> ID, ‘Location’, true);?>, add exactly.

    When it is activated in the settings, the CFs are shown in the description as an entire block.

    So, just exactly the view settings.

    Cheers

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] remove custom field data from the excerpt’ is closed to new replies.