Support » Plugin: Comments - wpDiscuz » Remove comment fields and enable recaptcha

  • Rodrigo

    (@vejapixel)


    Hello guys,

    Is it allowed to remove the comment field, such as the site field? This website field encourages spammers to keep commenting just to enter their website address.

    Is it possible to also add a recaptcha to avoid comments from robots?

    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support gVectors Support

    (@gvectorssupportmember)

    Hi @vejapixel,

    Is it allowed to remove the comment field, such as the site field?

    Please use the following CSS code:

    .wpd-form-wrap .wpd-form-row .wpd-form-col-left .wc_website-wrapper{
    display:none;
    }

    Put the code in the Top Admin Bar > Customize > Additional CSS > “Additional CSS” textarea, save it, delete all caches and check again.

    Is it possible to also add a recaptcha to avoid comments from robots?

    wpDiscuz 7 comes with built-in Google reCAPTCHA version 2 (I’m not robot). You just need to register your domain with Google to obtain the Site Key and Secret Key for reCAPTCHA Version 2.
    More info here: https://wpdiscuz.com/docs/wpdiscuz-7/plugin-settings/google-recaptcha/

    If you want to use the latest Version 3 – Invisible Google reCAPTCHA, please check out the wpDiscuz reCAPTCHA addon. This will make your commenter’s life easier, without even checking the version 2 checkbox.

    Rodrigo

    (@vejapixel)

    Does the plugin work well in the AMP version?
    I am using the “reCaptcha by BestWebSoft” plugin, but in the AMP version reCaptcha is not working. So, I would like to know if the wpDiscuz plugin’s reCaptcha will work correctly.
    I am using the official AMP plugin.

    Plugin Support gVectors Support

    (@gvectorssupportmember)

    Hi @vejapixel,

    We’re sorry but we not familiar with AMP plugin. You can simply test it using built-in Google reCAPTCHA version 2 (I’m not robot) and see how it work.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.