Support » Plugin: The Plus Addons for Elementor Page Builder » remove cache functionality

  • Resolved ash.rowe

    (@ashrowe)


    is there an option to completely remove the cache functionality within the plugin but keep everything else?

    it is definitely not compatible with wp rocket/autoptimize and other caching plugins that i would prefer to use.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author POSIMYTH

    (@posimyththemes)

    Hello @ashrowe

    Unfortunately, You can not disable that feature from our plugin. As, It’s deeply integrated and core part of the plugin.

    We have the most advanced performance architecture built-in. Which generates one CSS and JS file per page to have only needed content on each page. Which keep all unwanted code away from a website.
    You may watch https://www.youtube.com/watch?v=bpHiSFiJfOc https://elementor.theplusaddons.com/elementor-news/performance-test-does-the-plus-addons-for-elementor-really-fast/

    Though, It works without any issues with all popular caching plugins as long as you don’t have very complex custom configurations in their settings.

    You should really make an option to remove cache from the plugin. It’s terrible. I have to disable elementor just to get a page to display properly.

    Plugin Author POSIMYTH

    (@posimyththemes)

    Hello @microscopes123

    We have added that in bug report tab in our roadmap area. https://roadmap.theplusaddons.com/boards/bug-reports/posts/remove-internal-caching-functionality We will try to include that soon in plugin.

    We are making this ticket as resolved, Still, If you need any help, You may reopen this or submit new ticket. We are always happy to help you.

    We are using many of the features from plus addons but the cache for us does not work and we find many widgets and even Plus addons widget looking broken unless you refresh the page, this is even without other cache options on the site although we do intend to use lightspeed cache.

    What would help us here is a way to disable the plus addons cache with a function.

    Is there any way we can do this?

    Plugin Author POSIMYTH

    (@posimyththemes)

    @bigeddev We are sorry for the inconvinience. Here is a link to explain a bit about our caching architecture, which helps to improve performance drastically. https://docs.posimyth.com/tpae/the-plus-addons-advanced-caching-configuration-things-you-should-know/

    The issue of cache you are having just might be browser cache or any other reason. Still, If you can submit a ticket to helpdesk, Our technical team can help you in-depth by having a look at your site and recording a video for you.

    About Disable cache option, We have that in list during our upcoming multiple performance-related updates, Which carries lots of improvements in plugin for better performance. Which includes Scan and disable unused widgets from TPAE, Elementor, Elementor Pro and many other features. Disable current caching will be also going to optional very soon, Most probably in few weeks.

    I purchased the premium version of this plugin and designed a mega-menu with Elementor.

    The first user to load the page see’s a horrible version of the mega menu. Each section is vertically stacked and takes up about 75% of the screen height (when it should be contained in a menu-sized bar).

    I thought it might be a conflict with Litespeed or Cloudflare and disabled both, but still the same issue. I then learnt that the plugin has its own cache feature and it appears this is causing this issue.

    I’ve been completely unable to use the plugin on my client’s site because of this issue above. I did attempt to speak to their support who’s only suggestion was “well the customer will just need to refresh the page to see it normally”. How this is their recommended solution for a paid product is beyond me.

    They’ve said for months that disabling their cache is ‘coming soon’ but after 3-months of waiting it’s getting rather tiresome.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.