WordPress.org

Support

Support » Themes and Templates » Remove avatar "lane", widen post text area

Remove avatar "lane", widen post text area

  • Hello 🙂 I have been tweaking with the theme on my new site for a few weeks now, and am becoming more familiar with how to make changes to suit my liking. However, there is one change that I haven’t found when I search the net and am hoping for some guidance.

    I’ve removed author avatars from page, post and category views, and it’s not happening on my home page, but post and category views have a lane where the text won’t go in the area where the avatar used to be. This “lane of blank” causes my youtube videos to have to be resized, as well as many images. On the home page, an image can be 500px, on the other pages I have to make them more like 380px.

    Can someone please tell me the files I would go into to change this? I think if I were pointed in the right direction I might be able to figure the rest out. Then again, I don’t even know what this area is called :/ am I referring to the container, or does that also encompass the sidebars?

    Signed, still learning 😀

    Thanks for any help in advance.

    PS: here is my web address: http://www.halodiehards.net Check out the home page, then choose a link w/ text and check out how much smaller the center text area gets :/

Viewing 15 replies - 1 through 15 (of 34 total)
  • you can try this in your css tab. under theme settings.

    div#content{width:97%;}
    div.item-list{width:98%;}
    div.activity-inner{word-wrap: break-word;position:relative;left: -80px;width:100%;}
    div.author-box{display:none;}
    div.post-content {position:relative;left: -90px;width:99%}

    You may need to tweak this some to fit your site.

    Thank you, Full Circle. I would prefer to go into the .css where the settings occur in the first place and make the changes there, to possibly avoid any conflict and to better find it if I run into problems in the future.

    Following is the .css for my theme as it is. As you can see, there is nothing here that looks like it would be the cause of the “avatar alley”. Can someone point me to where in the WordPress files I might find that code?

    `.aligncenter {
    display: block;
    margin-left: auto;
    margin-right: auto;
    }

    .alignleft {
    float: left;
    margin-right: 15px;
    }

    .alignright {
    float: right;
    margin-left: 15px;
    }

    div.post .wp-caption {
    text-align: center;
    background-color: #f3f3f3;
    padding-top: 4px;
    -moz-border-radius: 3px;
    -webkit-border-radius: 3px;
    border-radius: 3px;
    margin-bottom:12px;
    }

    div.post dd.wp-caption p.wp-caption-text, div.post .wp-caption p.wp-caption-text {
    font-size: 0.9em;
    line-height: 17px;
    padding: 0 4px 5px 0;
    margin: 0;
    }

    In Custom Community the css is stored and pulled from the database. The settings I gave will override the defaults. No conflict.

    Finally worked up the guts to try this (been sick and I’ve had things nerfed to where it tooks hours to fix, knew I didn’t have the energy for that!) and it worked beautifully! Thank you so much 😀

    PS: For anyone researching this fix – A couple months ago I tried to do a css fix under theme settings in the css tab. For some reason Custom Community only allowed the one css edit and it nerfed, then there was no reset button or way to delete the css I had added. So when I did that a couple months ago and it broke my site, I had to upload my backup and it took me hours to get everything set up the same again. For this reason, I just pasted the above code in wordpress>wp-content>themes>custom-community>style.css and it worked beautifully!

    Whoops! Spoke too soon; now content from NextGEN Gallery isn’t lined up right :/

    http://www.halodiehards.net/halo-fan-art/

    Here’s a possible important bit of info: The thumnails that were displayed prior to the css fix display accurately. The thumbnails uploaded after the css fix (just now) are the ones from the link above.

    try removing div#content{width:97%;}
    see what you get.

    I removed div#content{width:97%} and I get exactly the same. Anything else I can try? Any code ya wanna see?

    Sorry it took me a bit to get back to you.

    Lets remove
    div#content{width:97%;}
    div.item-list{width:98%;}
    div.activity-inner{word-wrap: break-word;position:relative;left: -80px;width:100%;}
    div.author-box{display:none;}
    div.post-content {position:relative;left: -90px;width:99%}
    and add —————————————————
    body.blog div#content{width:97%;}
    body.blog div.author-box{display:none;}
    body.blog div.post-content {position:relative;left: -90px;width:99%}
    body.single div#content{width:97%;}
    body.single div.author-box{display:none;}
    body.single div.post-content {position:relative;left: -90px;width:99%}

    ————————————–end add

    This will make the css only effect the posts pages, and not all.

    Hey, no problem taking awhile to get back to me: I appreciate the help! 🙂

    So I think we’re getting closer to the problem. For clarity I will recap. My problem was that posts in category and post pages had a blank inch or so between them and the sidebar, where the avatar had been before I deleted it. The first code fix you gave me corrected the space in category view, but made it disappear under the left sidebar in post view. The second code fix you gave resulted in everything staying that same as that. This third fix caused the posts in category view to once again have the “avatar alley” but post pages remained hidden under the left sidebar, so I changed it back to fix #2.

    To be totally clear, I’ve returned the css back to this (we had deleted div#content{width:97%;} with no change):

    div.item-list{width:98%;}
    div.activity-inner{word-wrap: break-word;position:relative;left: -80px;width:100%;}
    div.author-box{display:none;}
    div.post-content {position:relative;left: -90px;width:99%}

    Now everything is back to how I like it except post view. Can we tweak the css so that our new settings don’t affect post view but continue to affect category view?

    Also, I am not sure where in the forums to ask this, but I would like to be directed to where I would find how the pages are titled for Category view. It’s calling the page the path, using the sub category name/s then the category, then my website. Looks awkward and I’d like to change it to be called simply the category.

    http://www.halodiehards.net/halo-fan-art/
    is this the only gallery page?

    So I checked the other gallery pages and that’s the only page I could find doing it. I deleted the post and reposted it and now it seems to be working fine 🙂

    Thanks again for your time.

    welcome

    I’m back O.o I guess there is at least one circumstance where this is still occuring: on search pages. I did a search and came up with this page:

    The page displays just fine when it’s linked to the post:

    I tried several searches and the same thing, any ideas?

    What the heck? I don’t know why it posted that way, and I can’t edit it for some reason.

    Let’s try this again:

    Here is the page when it’s the post via a search:

    http://www.halodiehards.net/?s=forerunner+symbols

    Here is the page when it’s directly the post:

    What is Requiem?

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘Remove avatar "lane", widen post text area’ is closed to new replies.
Skip to toolbar