Support » Requests and Feedback » Remove Ancient Plugins

  • Please remove plugins which have not been updated for years. When I am searching for a plugin, I see there are a lot of expired plugins, even those that have not been updated for 4 years.
    Removing such plugins will help to declutter the repository and provide better user experience and smooth search navigation.

Viewing 8 replies - 1 through 8 (of 8 total)
  • What if those plugins haven’t been updated for that long because they don’t need to be? Not everything that’s old means that it’s been abandoned.

    I personally use one pluign on all of my sites that’s over 3 years old, and it while it’s only relatively simple, it still works exactly as it’s meant to, so there’s no reason to stop using it.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    Removing such plugins will help to declutter the repository and provide better user experience and smooth search navigation.

    In your dashboard (not here), unless you explicitly put in the slug for a plugin then you will not see any plugin 2 years old or older.

    On this site? It’s nothing to declutter. Sometimes people really do want to find that old plugin and old doesn’t mean it doesn’t work for them.

    Moderator Andrew Nevins

    (@anevins)

    Front-end developer

    Deleting plugins sounds like the harshest solution to cleaner results, perhaps you’d want a filter on your search instead.

    I use old plugins. Because they still work!

    Glenn

    (@rglennnall)

    yes, but only the very ancient – i have Favorite plugins that haven’t been touched in two years.

    But there must be a way for we, the users (remember us?), to flag problem plugins as “unworking,” “contains virus,” etc. (considering the problem ya’ll just had 4 times with such a plugin).

    Moderator Andrew Nevins

    (@anevins)

    Front-end developer

    But there must be a way for we, the users (remember us?),

    @rglennnall, I should just clarify that moderators are not WordPress. We are real users as well and we just happen to help out on the forums.

    You’re confusing insecure plugins with old plugins. Insecure plugins do need to be dealt with and that is not the topic being discussed here.

    Glenn

    (@rglennnall)

    the title of this topic is “Remove Ancient Plugins.”

    I am trying – against the odds, obviously – to get my voice heard by WORDPRESS Plugin Repository developers – if you could please show me where this might be possible, I’d gladly remain quiet where it doesn’t do any good.

    Glenn

    (@rglennnall)

    But there must be a way for we, the users (remember us?), to flag plugins – for our own benefit – as doesn’t work, already tested, etc…

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.