Support » Plugin: Contact Form 7 » Remove admin email from getting emailed

  • Resolved landed

    (@landed)


    I looked through docs and FAQ’s suprised not to see this here.
    I am getting an email for each form submission. I wan’t just the email to go to the one specified in the form not the admin email as well.
    Where can I stop this happening.

    Scenario: I manage the client site and need my email as the admin email but I don’t want that email to get notified when a form gets submitted. Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • User

    (@saltennys)

    Perhaps you forgot to edit the To field of the Mail template?

    https://contactform7.com/setting-up-mail/

    Because by default, it’s set to the blog/site admin email.

    So if your Form template contains an email field named your-email, you’d put [your-email] in the To field of the Mail template.

    Thanks but alas I am using the field correctly 🙁

    User

    (@saltennys)

    Try to disable all plugins (except Contact Form 7), but one at a time. Each time after you disabled a plugin, go test one of the problematic forms, and see if the problem persists. If not, then that plugin you’ve just disabled is in conflict with Contact Form 7.

    But first off, switch to the default theme (i.e. Twenty Seventeen). If the problem goes away, then this is a theme issue/conflict.

    Hmmm, I don’t think this is going to work I in fact run jetpack and that’s about it. There should be no conflict as sending a mail is very different to what the other plugins do.

    User

    (@saltennys)

    I looked through docs and FAQ’s suprised not to see this here.

    — Now I wonder which docs and FAQ’s you read?

    If the forms are generated and handled by Jetpack and not Contact Form 7, then try to get assistance on:

    https://wordpress.org/support/plugin/jetpack

    If you’re saying that the only plugins used on the site are Jetpack and Contact Form 7 …, then you can still apply the same steps (that I suggested in my previous reply) in troubleshooting the problem.

    • This reply was modified 1 year, 6 months ago by  User.

    I looked through the contact form 7 docs.

    “If the forms are generated and handled by Jetpack and not Contact Form 7, then try to get assistance on:”
    I am not sure I understand you, I am not using jetpack for forms, I will investigate this if it is possible. Thanks you might have given me enough insight.

    No there doesn’t appear to be a form related thing for jetpack.

    • This reply was modified 1 year, 6 months ago by  landed.
    User

    (@saltennys)

    I was just a bit curious whether you used the Jetpack contact form module and not Contact Form 7. 🙂

    Just try the steps I mentioned, alright? Including switching to the default theme. Only for a while.

    Also, check this out if you haven’t, because it might help you:
    https://contactform7.com/jetpack-overrides-contact-forms/

    Here is a screen shot below of my settings… seems the contact form is not set to conflict thought the jetpack screen shots are now different I could not see any where they now do a contact form…

    https://www.evernote.com/l/APEspyd0-ENFMLDHnHkUCDC-kGfn0iGWOdU

    User

    (@saltennys)

    Referring to the screenshot, try to change the “To” field to [your-email].

    Thank you for all your help. I think it is now working correctly. I have no idea why unless my admin email is not working or I got lucky thanks again.

    User

    (@saltennys)

    I’m happy to hear that!

    And I think it’s working now because you no longer using your email address in the “To” field.

    So, don’t use your email address there, unless you actually want to receive an email everytime someone fills out the form.

    No you are wrong I didn’t have it setup wrong as described – https://www.evernote.com/shard/s241/sh/2ca72774-f843-4530-b0c7-9c79140830be/9067e7d2219639d5

    And it’s still sending me emails. 🙁

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Remove admin email from getting emailed’ is closed to new replies.