Support » Theme: Shop Isle » remove add to cart hover over

  • Hi .I’m using the Shop Isle theme. I’m looking for a way to remove the “add to cart” hover over button that appears over all products in my shop WITHOUT removing the stationary “Add to cart” button from the final product detail page; everything i have tried so far gets rid of the “add to cart” all together not allowing my products to be sold. I still want to be able to sell my products. I just find the hover over in my shop intrusive when browsing over the product in my shop.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi @ether11,

    Sorry for my late reply. Let me better understand this. You are saying you want to remove the effect on button hover? The one that changes the color of the button? ( ). Or do you want the buttons to be always visible like they are on the mobile version ( ) ?

    Best regards,

    @cristian-ungureanu hi, could you explain me how to change the buttons to look like the link you gave us?
    I would like to change the style to that, because im having problems using “Spanish Language”, making the button text too long and bugging with the ajax thing.
    I would like to try using ajax on, but with that type of button, is there a way to make the “ajax” effect go BEHIND the real button, and not in THE SIDE ? Please help me.
    Here is a screenshot of my problem. The only way to fix it is disabling ajax for the button for me right now, but is awful, when u add to cart in the homepage, it just refresh without a “view cart” and then when you go to the store, it shows u a hundred view cart.
    I just need to get the button ajax thing to be BEHIND the “Add to cart” and not next to it.
    Thank you, here is the link of the screenshot:

    @cristian-ungureanu could you help me please, im so confused with this theme “shop-isle”, now “Add to Cart” and “View Cart” is fixed with the ajax thing, it looks like in your post, where the “View Cart” is below the “Add to Cart”, but… now “Choose Options” is bugged, BUT only in the MAIN PAGE.
    If i go the store, everything is working perfectly.
    I just dont know what to do now.
    Here are the links of the screenshots, both main site and store site. [Home Screen with the bug ] [Store screen, which looks perfect without the bug…]


    Hello, just wondering if the original poster @ether11 figured this out. I am also trying to remove the add to cart hover button from the product category pages and anywhere else it appears. Thanks.

    If anyone is interested, I tried this custom css and it works, at least for woocommerce 3.5.4 and shopisle 2.2.46:

    ul.products li.product .product-button-wrap .add-to-cart-button-wrap .button, .add-to-cart-button-wrap .button {
    display: none;

    @wbranley thank you SO MUCH! It works on the latest version as of date of posting!
    Any idea how to remove the light overlay that appears on hover?

    @wbranley – Any idea how to remove the light overlay that appears on hovering over a product image after adding your code?
    See image:

    @champagnecoffee – Actually I didn’t try to remove that hover behavior because I didn’t mind it so much. I can’t think of an immediate solution other than to override the existing hover with a different hover. Good luck!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘remove add to cart hover over’ is closed to new replies.