Support » Plugin: Years Since » Remote “years” word

  • Resolved nathanwright

    (@nathanwright)


    Hi, it would be a much better plugin if it didnt include the word ” years” itself and just returned the number.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author johnalarcon

    (@johnalarcon)

    Hi Nathan,

    Not a bad idea. I’ll get this into the next version, which should push by Wednesday. Thanks for the suggestion.

    Cheers,

    – John

    Hi John

    I am already using your plugin on a website I am just finishing of at http://www.gdprhelp.je

    I am using it on the homepage and on the Hand Holding page, I also plan to use it on my consultancy business website as well in the next few days once you have removed the “years” and just return the number.

    Cheers

    Nathan

    Plugin Author johnalarcon

    (@johnalarcon)

    I’m going to leave this thread open as unresolved and will update it when I push the change out. Rather than removing the text, I’ll add an extra argument to the shortcode to optionally suppress it. Thanks again for the suggestion.

    Alternatively you could add an option to change the text eg t=”my text” and if t has a value then you use that instead of years and if it doesn’t then you add the ” years”. This way for my example I can just add t=”+” and the result would be “23+”

    This gives people total flexibility.

    Plugin Author johnalarcon

    (@johnalarcon)

    Thanks for the additional suggestion.

    My reservation with that approach is that it does not account for pluralization, so end-users would have to manually update (add or remove the “s”) to keep the language correct (ie, 1 year, 2 years). Since the goal of the plugin is to create an automatically updating experience, I’ll be unable to implement the feature in this way.

    Instead, I’ve added another parameter to the shortcode to suppress the text. Simply add text=false to your shortcode and only the number will be returned.

    I’ve pushed this change out, but found that my version numbers didn’t work properly to trigger the update notice in the dashboard. Sorry about that; the new version is corrected so update notices will work as expected. Please deactivate, delete, then re-install the plugin and you’ll be all set. There’s no need to delete any shortcodes you may have already placed – they’ll be fine through deletion/re-install.

    Let me know if you run into any trouble.

    Cheers!

    Thanks again for the suggestion!

    Ah yes that is a good point, I will download shortly and let you know how it goes.

    Cheers

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Remote “years” word’ is closed to new replies.