WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Remote publishing option gone? (10 posts)

  1. argeedblu
    Member
    Posted 7 months ago #

    It's been a while since I have published. When I do, my practice has been to write the article using Windows Live Writer then publish the article directly from Writer. This morning the publish failed. When I checked my WordPress settings, I could not find the Remote Publish option. Where has it gone and when will it be back?

    Glenn

  2. Where in settings are you looking? The XMLRPC settings should be on for everyone all the time.

  3. argeedblu
    Member
    Posted 7 months ago #

    Hi Mike,
    I'm looking in Writing Settings. All that is there now is Post by Email. Aparently the option was removed with version 3.5. I found a thread <a href="http://http://wordpress.org/support/topic/remote-publishing-settings-are-missing?replies=5"> that suggested that an Atom plugin is required now but I still can't publish from Writer even after installing the plugin.

    Glenn

  4. Right, so what was removed was the OPTION to turn it on or off. It's always on now :) You shouldn't have any issues unless you've disabled it somewhere else OR your host has disabled it due to brute force attacks.

    Check that the file xmlrpc.php exists (you can go to example.com/xmlrpc.php to test). If you see "XML-RPC server accepts POST requests only." then it's working

  5. looplooks
    Member
    Posted 7 months ago #

    I just got off support chat with GoDaddy and they indicated that they disabled everything that uses xmlrpc.php because there is a security vulnerability with it. Basically what they told me is that Windows Live Writer won't work until WordPress releases a patch to fix the vulnerability.

  6. argeedblu
    Member
    Posted 7 months ago #

    looplooks, that is disappointing but thank you very much for the information.

  7. StuBee
    Member
    Posted 7 months ago #

    I had two Godaddy issues. A network one, and this xmlrpc one. Finally they fixed the network one, and I just found the workaroudn for the xmlrpc block.

    Rename the xmlrpc.php file on your wordpress install. THen change your windows livewriter to refrence that new filename during the blog setup.

    Works !

  8. argeedblu
    Member
    Posted 7 months ago #

    Stubee,

    Thanks for that. I have renamed the file in my WordPress installation but I am having difficulty setting up the livewriter connnection again.

    My installation is in the root directory of my domain but I can't seem to get the <hostname> and <path> correct. My blog address is http://www.officetipsandmethods.com so I am specifying the hostname as http://www.officetipsandmethods.com and / for the path but LiveWriter says that it can't make the connection.

    Any suggestions as to what I am doing wrong?

  9. I just got off support chat with GoDaddy and they indicated that they disabled everything that uses xmlrpc.php because there is a security vulnerability with it.

    Ugh. Okay, NO it's not that. I mean, yes, but really it's being brute forced right now and ... disabling it is going to break all sorts of things.

    argeedblu, http://www.officetipsandmethods.com/yourxml.php

    Whatever you named the xml file would be that

  10. argeedblu
    Member
    Posted 7 months ago #

    Color me embarrased. I've been using GUI's so long I had forgotten how to hand code a path. Thanks for your help Stu and Kika. I have now hooked livewriter back up to my blog

Reply

You must log in to post.

About this Topic

Tags

No tags yet.