Support » Plugin: Sessions » Remote IP sessions all 127.0.0.1

  • Resolved scottgx

    (@scottgx)


    The Active Sessions Management page shows the Remote IP is 127.0.0.1 for every session.

    Is there a way to fix it, to show the real IP for each?

    Thx.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Hello @scottgx !
    Sorry to hear that… And that’s very strange. Could you give me details of your set-up? It may come from how you have set your server, proxy, etc…
    If you feel uncomfortable to share this publicly, let me know, we’ll communicate by email.

    I did the standard install of WordPress on my hosting company’s website.
    Where do I find the information you need? Within WordPress or the hosting company account page?

    Server Information
    Item Detail
    Server Name ecbiz261
    cPanel Version 86.0 (build 18)
    Apache Version 2.4.43
    PHP Version 7.2.24
    MySQL Version 10.2.31-MariaDB-log
    Architecture x86_64
    Operating System linux
    Shared IP Address 173.231.209.32
    Path to Sendmail /usr/sbin/sendmail
    Path to Perl /usr/bin/perl
    Perl Version 5.16.3
    Kernel Version 3.10.0-962.3.2.lve1.5.31.el7.x86_64

    My WordFence Diagnostic section shows this:
    IP Detection Methods of detecting a visitor’s IP address.
    IPs Value Used
    REMOTE_ADDR 127.0.0.1 In use
    CF-Connecting-IP (not set)
    X-Real-IP (not set)
    X-Forwarded-For (not set)
    Trusted Proxies (none)

    After disabling Sessions and Decalog, WordFence now shows the real remote IP address.

    Also note, when disabling Decalog, it still shows in the WordPress menu under “PerfOps Settings”… “Control Center” and “Decalog”.

    Trying to delete the Decalog plugin gives this error: “Deletion failed: There has been a critical error on your website. Learn more about debugging in WordPress.”

    I deleted Decalog plugin via FTP.

    I reactivated Sessions (now without Decalog)… WordFence now shows all traffic as IP 127.0.0.1 again. And all Active Sessions show Remote IP as 127.0.0.1.

    So, I will have to deactivate Sessions until it is fixed.

    I hope this info helps.

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Hello!
    What if you try to uncheck “Override WordPress” for IP detection in settings (in Sessions, because I think DecaLog has not influence on this)? Is it ok in Wordfence? Is it ok in Sessions ?

    I clicked to uncheck Override WordPress, clicked Save Changes, the page refreshes, and at the top it shows “Plugin settings have been saved.” However, Override WordPress is still checked. I tried it again and same happens. The uncheck does not stay.

    All Remote IPs are again 127.0.0.1.

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    OK, that’s a sum of strange things…
    First, in Sessions settings, click on “reset to defaults” then uncheck the checkbox and it should stay “unchecked”.
    Let me know what your viewing as IP in WordFence and in Sessions…

    scottgx

    (@scottgx)

    That worked! Clicking “Reset to Defaults” and unchecking “Override WordPress,” saved, it stayed unchecked. The IPs in WordFence and Sessions now appear to be the real IPs.

    THANK YOU! 🙂

    Request for change: In the WordPress main menu on the left, there are three “PerfOps” menu items each with submenus. I think it would be nicer to have one “PerfOps” main menu and then everything else under that.

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Haa! That’s good news 🙂

    Regarding the reason why there’s now 3 menus, it’s because there’s “many” PerfOps plugins (all “system” plugins here: https://profiles.wordpress.org/pierrelannoy/#content-plugins) and so if you have 3 or 4 or 5 of them, all settings are in the same menu, all analytics in the same etc…

    Regarding the glitch in the saving of the “unchecked” options, it will be fixed in the next version. Thanks for pointing it out.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.