Support » Fixing WordPress » Remote Database connection

  • Resolved hoiikmaak

    (@hoiikmaak)


    We have an assignment from school. Make 2 ubuntu servers, 1 with wordpress and 1 with a database server. Then setup WordPress and use the remote database server.

    I have made this setup locally in virtual box.
    Ip: My desktop 10.0.1.1, ubuntuserver1(wordpress) 10.0.1.2, ubuntuserver2(database) 10.0.1.3

    I have everything installed and database has been created. Then when I go to http://10.0.1.2/wp-admin/setup-config.php?step=1, and try to configure the database it isn’t working.

    I tried to check if the database is available from 10.0.1.2 to 10.0.1.3 with the user I have made for the database, and I’m able to connect and see the database.

    
    --------------
    mysql  Ver 15.1 Distrib 10.1.43-MariaDB, for debian-linux-gnu (x86_64) using rea
    
    Connection id:          3
    Current database:
    Current user:           wpuser@10.0.1.2
    SSL:                    Not in use
    Current pager:          stdout
    Using outfile:          ''
    Using delimiter:        ;
    Server:                 MySQL
    Server version:         5.7.28-0ubuntu0.18.04.4 (Ubuntu)
    Protocol version:       10
    Connection:             10.0.1.3 via TCP/IP
    Server characterset:    latin1
    Db     characterset:    latin1
    Client characterset:    utf8mb4
    Conn.  characterset:    utf8mb4
    TCP port:               3306
    Uptime:                 50 sec
    
    Threads: 1  Questions: 5  Slow queries: 0  Opens: 105  Flush tables: 1  Open tab
    --------------
    
    MySQL [(none)]> show databases;
    +--------------------+
    | Database           |
    +--------------------+
    | information_schema |
    | wordpress          |
    +--------------------+
    2 rows in set (0.00 sec)
    

    I have tried many things however, at this moment I’m clueless what to try.
    I can start and run the installation, however when I press the button, it stops and:

    
    This page isn’t working 10.0.1.2 is currently unable to handle this request.
    HTTP ERROR 500
    

    shows up.

    All things can help 😀 !, please if something comes to your mind tell me.

    – Tom
    The links I have used:

    Main
    https://www.tecmint.com/install-wordpress-on-ubuntu-16-04-with-lamp/
    Ports
    https://www.cyberciti.biz/faq/linux-apache2-change-default-port-ipbinding/
    Mysql
    https://help.ubuntu.com/lts/serverguide/mysql.html
    PHP
    https://askubuntu.com/questions/873768/how-do-i-install-php7-on-ubuntu-14-04
    Remote
    https://www.linode.com/docs/databases/mariadb/configure-wordpress-remote-database/

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Remote Database connection’ is closed to new replies.