Support » Plugin: WooCommerce Stripe Payment Gateway » “Remember Me” unchecked, cards still getting saved

  • Resolved Justin Busa

    (@justinbusa)


    Hello,

    With the “Remember Me” checkbox unchecked upon checkout, a user’s card is still being saved to the site. Is that the expected behavior or should cards not be saved with that unchecked? Here are some screenshots showing that…

    Thanks for your help!
    Justin

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    Justin,

    Is the product a standard(simple) product, or is it a subscription product? Is the user logged in or a guest?

    Justin Busa

    (@justinbusa)

    Hey Thomas,

    Thanks for the follow up. The product is a simple subscription and the user is logged in.

    I just tested as a guest that creates an account upon checkout and got the issue there as well.

    Let me know if you need any more information.

    Justin

    Plugin Author royho

    (@royho)

    @justin, this should be fixed in the next release.

    Justin Busa

    (@justinbusa)

    Perfect, thanks!

    Plugin Author royho

    (@royho)

    @justin – So sorry. I thought there would be a way to get that setting in the response object however after speaking with Stripe’s dev team, they said that setting is currently NOT passed back in response and therefore our plugin has no knowledge of it.

    I am not sure if you’re just wanting to give users the option to save their detail or not but if you don’t want anyone to save their details, you can simply turn that feature off. In the next version, “allow remember me” setting will be removed completely in favor of the “Saved Cards” setting that is already there which is redundant actually.

    Justin Busa

    (@justinbusa)

    @royho no worries, it’s not a huge issue. The changes in the next version sound like they will work just fine for this.

    Thanks!
    Justin

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘“Remember Me” unchecked, cards still getting saved’ is closed to new replies.