Support » Plugin: AMP for WP - Accelerated Mobile Pages » rel=”noreferrer” issue in affiliate link in amp for wp

  • Resolved Bulbul Bigboss

    (@bulbulbigboss)


    in non amp version my affiliate link rel=”nofollow” but in amp version this link rel=”nofollow noreferrer”

    in amp version, it automatically added noreferrer in rel attribute.
    N.B> I am not using target=_blank

    This is a serious issue for an affiliate link? Because Market place doesn’t count it as referral traffic? they are counting it as their direct traffic?

    Fix it as soon as you can? Otherwise, all the niche site using the amp for wp is experiencing losses.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    That’s really strange,

    1) Can you please update to the latest version and check if this is still happening?
    2) Can you please share the URL where you are having this issue?

    Last version created the problem!!

    Here is the screenshot of desktop version
    https://drive.google.com/file/d/1LB1pzSgRcWFy7rSxdJeL_SWUOIWZYP3s/view?usp=sharing

    Here is the screenshot of amp version
    https://drive.google.com/file/d/1ua7Su9-MWIzecgNKW0DCcbR8ehpya01l/view?usp=sharing

    Plugin is up to date.

    I can’t share my site publicly? I already send site link in your official website support section.

    N.B> I am thinking to uninstall your plugin!! Because of losing money!!

    I have added this code on functions.php it working for desktop version but not working in amp. I think redux_builder_amp created the issue.
    I am using template design3

    `//remove noreferrer on the frontend, but will still show in the editor
    function im_formatter($content) {
    $replace = array(“noreferrer” => “” );
    $new_content = strtr($content, $replace);
    return $new_content;
    }
    add_filter(‘the_content’, ‘im_formatter’, 999);

    I have checked some of the other sites using the amp for wp has the same issue in rel=”nofollow noreferrer”
    I can share you the screenshot.

    This problem is not only in their site who used a plugin for affiliate link generate.

    I can share screenshot with you.

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    1. I tried opening those screenshots, but I need the permission to open it so I have requested for the access.
    2. a link of the site would really help me fix this issue, kindly send there.

    I’m sorry for this issue and I understand that it’s an important one. As soon as I see it, I will make sure we fix it. Meanwhile, you can rollback to an older version on your site as an alternative version.

    Bulbul Bigboss

    (@bulbulbigboss)

    Ok, Thanks for the reply. Please check the screenshot now.

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Thanks, but I understood that from the first message but I need to recreate it on my end. Can you share the input?

    Are you adding in the classic editor or gutenberg?

    and please share the content markup so I will also add the same content on my localhost and try to see the output of the link and then make changes to the code.

    Bulbul Bigboss

    (@bulbulbigboss)

    I am using classic editor. I can’t share mark-up because, it has my affiliate tracking code.

    You can install your plugin in local-host, add a link from classic editor with rel=”nofollow” open it in amp, I am sure you will get same result, I was talking about.

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Thank you for the detailed help, I was able to re-create the issue. here’s the bug report: https://github.com/ahmedkaludi/accelerated-mobile-pages/issues/3566

    Our developers will start working on this immediately!

    Bulbul Bigboss

    (@bulbulbigboss)

    Ok, Fix it as soon as you can. I will changed my review after getting result.

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Thank you for understanding.

    We are going to push this in the upcoming updates by the end of the week.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.