Support » Plugin: Relevanssi - A Better Search » Relevanssi update broke media library search function

  • Resolved azariosays

    (@azariosays)


    Hi,

    I’m updated Relevanssi to Version 4.7.1. However, now when I do a search in the Media Library of a post, it says that there’s nothing there. I’ve deactivated Relevanssi and the Media Library search works again. Is there a setting or something that I’m doing wrong that this is happening? Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mikko Saari

    (@msaari)

    Version 4.7 enabled Relevanssi in Media Library searches. This problem may occur if Relevanssi is enabled in the admin searches and the attachment post type is not indexed. I need to fix this so that if that’s the case, Relevanssi is disabled in the Media Library search.

    Meanwhile, there are two easy fixes for this: you can either disable Relevanssi in the WordPress admin from the Searching tab of Relevanssi settings, or you can have Relevanssi index the attachment post type. Both should solve this problem.

    Thread Starter azariosays

    (@azariosays)

    Awesome, that worked, thank you!

    Thank you. I also had the same issue and found that the latest Relevanssi update was causing the problem.

    I have the same issue, both admin search and index attachment post type are enabled.

    Plugin Author Mikko Saari

    (@msaari)

    @sannny If you have admin search enabled and have indexed attachments, you have a different issue. Please start a new thread, as this one’s already marked resolved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Relevanssi update broke media library search function’ is closed to new replies.