Support » Plugin: Relevanssi - A Better Search » Relevanssi not searching excerpts

  • Resolved lklawless


    Never mind: I realized that the solution was to add “vegetarian” to the stop words. I’ll leave this post in case anyone else has a similar problem, or feel free to delete it if it’s of no value. Thanks again for an awesome plugin!

    Hi –

    I’m getting some erroneous results, I think because Relevanssi is not searching the excerpt. (I have WP custom excerpts enabled but not Relevanssi custom snippets.)

    If you search my site for picnic, the top result is a page called picnic recipes, and you can see the word “vegetarian” in the excerpt.

    But if you search for vegetarian picnic, that page isn’t included in the results.

    ETA: I guess it’s not the excerpt, because I discovered that if I reverse the search terms to picnic vegetarian, I get a lot more results, including the picnic recipes which come up in 3rd place.

    Any ideas?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mikko Saari


    Relevanssi indexes excerpts, if you make it do so in the settings page.

    This is a problem related to limit; if you adjust the limit higher or disable the option completely, this problem should disappear.

    Hi, thanks for responding.

    I have Relevanssi set to index excerpts, and the search term appears in the body of the post too, but R still was not finding it.

    I don’t understand why the limit matters, since it was only finding 2 results, nowhere near the limit of 500. I disabled it, and now it’s finding no results, so I’m putting “vegetarian” back as a stop work.

    Thanks anyway.

    Plugin Author Mikko Saari


    How many posts you have that have the word “vegetarian”? More than 500? Because if you have, and you’re using an AND search, then with a limit of 500, it may be the “vegetarian picnic” post you’re looking for doesn’t make it the cut of 500 for “vegetarian” and then cannot be found with an AND search, which would require both words to be present.

    That’s why the limit matters, and that’s why the order of words matters.

    That makes sense, thank you.

    But when I removed the limit, the search came up with no results, even though it had come up with two with the limit.

    Since adding “vegetarian” to the stopwords makes sense for my site and brings up the expected results, I’ll stick with that.

    Thanks for taking the time to explain.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Relevanssi not searching excerpts’ is closed to new replies.