• I get this error –

    Relative URLs are disallowed for attribute ‘helper-iframe-url’ in tag ‘amp-web-push’.

    and

    Relative URLs are disallowed for attribute ‘helper-iframe-url’ in tag ‘amp-web-push’.

    All blog posts have same problem.

    When I test for AMP, it shows this –
    The relative URL ‘//177242-514694-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/accelerated-mobile-pages/includes/onesignal-integration/amp-helper-frame.html?appId=782ec3b4-8d9a-48f9-88aa-c83b03f33401’ for attribute ‘helper-iframe-url’ in tag ‘amp-web-push’ is disallowed.

    That’s the stackpath URL for my blog and its pretty common to have that for images. Now I have to disable CDN function in order to fix this issue. Further I might have to disable the OneSignal push notification too. Please help me fix this issue.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    I have tested your issue and seems that CDN urls that starts with ‘//’ instead of ‘https:’ because of the CDN implementation. If you fix this issue, this validation issue will be solved.

    For example, you can check this: http://tinyurl.com/ue6y9wq

    Thread Starter Yogesh Khetani Patel

    (@yogeshpatel37)

    I had similar issue with one of my other blog using the same hosting and same CDN provider (stackpath in this case). I don’t remember how I fixed that issue but if you look at the URL those have the same CDN URLs that start with “//”.

    You can have a look at the site here
    That blog has things in perfect, why not this one.

    Update: With Hosting provider, I have updated the CDN CNAME to include https:// but still the pages isn’t AMP compatible and shows an error.

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    You are facing problem with the link because in Push notification support ‘OneSignal’ option is enabled and it is only compatible with URLs that begin with https://.

    So either you can disable ‘OneSignal’ option or fix it by using ‘https:’.

    Thread Starter Yogesh Khetani Patel

    (@yogeshpatel37)

    Update: I have removed the CDN, some help, please! Can you confirm now?

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Do find any option where we can exclude certain files from stackpath CDN? If you find any then we can exclude one signal files form that list and serve it from the hosting.

    That should resolve the problem.

    Thread Starter Yogesh Khetani Patel

    (@yogeshpatel37)

    Thanks for your reply and cooperation in this regard Ahmed but even after removing CDN my problem does exist (same problem). So excluding CDN files and further I have disabled OneSignal. Is the problem because of I activated the Onesignal integration? If that is the case then I have a similar configuration with same hosting plan at Cloudways for . There CDN is also working fine.

    I re-installed the plugin too.

    Disabling the Onesignal will fix the problem normally but in this case, it doesn’t.

    Update: Still my problem hasn’t been resolved.

    • This reply was modified 4 years, 6 months ago by Jan Dembowski.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Relative URLs are disallowed for attribute amp-web-push Error’ is closed to new replies.