Support » Plugin: Pods - Custom Content Types and Fields » Relationship field type – display custom field

  • Resolved josesreis

    (@josesreis)


    Hello.

    I’d just started yesterday and i’m already amazed with PODS framework for WordPress.

    I’m following the video PODs for begginers and already searched google and this forum and looked at Additional Field Options.

    I have 2 custom types “Edital” and “UF”. Every “Edital” has one “UF”, but one “UF” can be related to several “Edital”s. So custom type UF {@npsau_uf} has the default {@post_title} and two other custom fields: {@npsau_uf_initials} and {@npsau_uf_name}.
    In the “Edital” entity we have a custom field named {@npsau_edital_uf} of type Relationship and related to custom type UF {@npsau_uf}. For the
    “Display Field in Selection List” int the “Additional Field Options” we set {@npsau_uf_initials} so that “Edital” record presents that custom type custom field instead of the default {@post_title}. Every thing works just fine, but when we edit an instance of “Edital” the follwing message is presented before the Edital–>UF field:

    Notice: compact(): Undefined variable: pod in C:\xampp\htdocs\testsite\wp-content\plugins\pods\classes\PodsData.php on line 3243

    Notice: compact(): Undefined variable: fields in C:\xampp\htdocs\testsite\wp-content\plugins\pods\classes\PodsData.php on line 3243

    Notice: compact(): Undefined variable: joined in C:\xampp\htdocs\testsite\wp-content\plugins\pods\classes\PodsData.php on line 3243

    Notice: compact(): Undefined variable: depth in C:\xampp\htdocs\testsite\wp-content\plugins\pods\classes\PodsData.php on line 3243

    Notice: compact(): Undefined variable: joined_id in C:\xampp\htdocs\testsite\wp-content\plugins\pods\classes\PodsData.php on line 3243

    Notice: compact(): Undefined variable: params in C:\xampp\htdocs\testsite\wp-content\plugins\pods\classes\PodsData.php on line 3243.

    Any ideas? As you can see, i’m using local XAMPP environment with up to date WordPress and plugins. IS there some debug flag that i have to switch off?

    Thank you!

    • This topic was modified 2 months, 2 weeks ago by  josesreis.
    • This topic was modified 2 months, 2 weeks ago by  josesreis.
    • This topic was modified 2 months, 2 weeks ago by  josesreis.
Viewing 3 replies - 1 through 3 (of 3 total)
  • I’ve tried other combinations for the Display Field in Selection List but the results were:
    {@npsau_edital_uf.npsau_uf_initials} – displays title
    {@npsau_uf.npsau_uf_initials} – display title

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    There’s a fix for these notices in the next release this week. You can turn them off by setting WP_DEBUG to false in your wp-config.php file

    Thanks Scott!!
    I was just worried of having something messed up.
    Thank you very much!
    Keep up the excelent work PODS Framework!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.