WordPress.org

Forums

Yet Another Related Posts Plugin (YARPP)
Relatedness options for titles and bodies stuck on "do not consider" (5 posts)

  1. njohns
    Member
    Posted 1 year ago #

    I installed and set up YARPP and it works perfectly for displaying posts but it will not show pages or show any related posts/pages on actual pages. I believe this is because under the Relatedness section in settings the drop down for titles and bodies is stuck on do not consider.

    I tried to fix this by following the steps under the message: "Consider Titles" and "Consider Bodies" are currently disabled. As a result, "Pages" may not display in the "Related Posts" sections.

    After I conveted the wp_posts table to the MyISAM engine and clicked the button below called "Create Fulltext indexes" I get another error message that reads "Fulltext Index creation did not work! Trying to force fulltext indexing on your table resulted in an error. Your posts table does not have fulltext indexing capabilities. The "consider titles" and "consider bodies" relatedness criteria will remain disabled."

    How can I fix this???? I would like related posts and/or pages to show up on pages in my website, not just on posts.

    https://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. njohns
    Member
    Posted 1 year ago #

    Here's a link to a page on my site... at the bottom you'll notice the "no related posts" message http://mvc.on.ca/about/

    Here's a link to a post on my site... you'll notice YARPP working fine
    http://mvc.on.ca/picnic-shelter-at-mill-of-kintail/

  3. mike_b
    Member
    Posted 6 months ago #

    Hi Njohns, did you ever fix this issue on your website. I followed exactly same procedure on mine and I'm seeing the same error message.

    Many of my blog posts like this one are not displaying any related posts.
    http://bc25.com/safety-items-always-in-backpack-backcountry/

  4. mike_b
    Member
    Posted 6 months ago #

    Can any one help with this?

  5. KriistianDavid
    Member
    Posted 3 months ago #

    Same here, it my website it says "no related post". Consider tittles and bodies are disabled. And i don't know how to convert wp_post to MyISAM.

    I tried deactivating plugin > delete yarpp content form wp_options > activating plugin. It doesn't work for me :/

    Is there another similar plugin?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yet Another Related Posts Plugin (YARPP)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic