WordPress.org

Forums

Yet Another Related Posts Plugin (YARPP)
"Relatedness" options are not working in Hebrew (10 posts)

  1. yoramzara
    Member
    Posted 2 years ago #

    I am using the plugin on 2 sites. One of them in English WordPress and the other on Hebrew WordPress.

    Both sites are on the same server, on WordPress 3.5.1, with the same theme and running Yarp 4.0.6

    On the Hebrew site the dashboard of the plugin is in Hebrew.

    There is an issue with the Hebrew site and the plugin
    Under "Relatedness" options in the English plugin I have a drop down menu for "Titles" and "Bodies". I can choose between: do not consider, consider, consider with extra weight

    In the English version these options are in black and I can truly choose any of them.

    In the Hebrew version the options: consider, consider with extra weight are in Grey and cannot be chosen.

    Can you please fix this?

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for reporting this. Let me look into this. What browser are you using?

  3. yoramzara
    Member
    Posted 2 years ago #

    I checked in IE, Chrome and FF. Same issue

  4. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 2 years ago #

    I checked this and couldn't reproduce it.

    Having "titles" and "bodies" disabled is often an indication that your wp_posts table is not using a MyISAM engine, so it can't compute keywords. Did you get a message about that?

  5. Yega
    Member
    Posted 2 years ago #

    Hi hi, I hope it's ok for me to post here, I believe I'm having a similar problem. (Please let me know if I should repost this elsewhere.)

    I've just started using YARPP, it seems to work pretty fine for my default language (Japanese), but not my translated language (English). In all my English posts there's always the same bunch of 'related posts', which of course in effect means that the 'related posts' are not related at all. How can I solve this problem?

    Also, where can I find the 'titles', 'bodies', 'consider', 'do not consider' options mentioned on this and other threads? I don't seem to be able to find any such options. There is a 'Related Posts' box underneath my main edit box, but there's nothing I can do there. This is what it says:

      These are the related entries for this entry. Updating this post may change these related posts.

      (shows related posts)

      Whether all of these related entries are actually displayed and how they are displayed depends on your YARPP display options.

    Other than a 'Configure' option on the top right corner, which brings me to the settings page, there's nothing else I can do here. I've already configured the settings page.

    There are 2 things that I don't understand here. First is, the 'related posts' that show up on the edit page is almost always different from what I see on the actual post page. Second, some of the churned out related posts are not really that accurate. I would like to fine tune this - I think this is where the 'consider', 'do not consider' options would help.

    Thannk you!

    BTW I'm using WP3.5.1, YARPP 4.0.6

  6. yoramzara
    Member
    Posted 2 years ago #

    I did not get any message on the dashboard. I can let you in my testing site and you can see for yourself

  7. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 2 years ago #

    @yoramzara sorry, I don't do direct support on sites. Are you sure that the wp_posts table is using MyISAM?

    @Yega in the YARPP settings page, go to the "screen options" tab (日本語では「表示オプション」) and show the "Relatedness" (関連スコア設定) options.

  8. lelebart
    Member
    Posted 1 year ago #

    hi, same problem here.

    italian locale, wp 3.5.2, localhost with XAMPP 1.8.2 (Apache 2.4.4, MySQL 5.5.32, PHP 5.4.16).

    the engine is recognized weirdly as 1 (one):

    ... the table seems to be using the 1 engine ...

    even with myisam_override set to 1, titles and bodies options are not selectable.

    YARPP usage data:
    http://pastebin.com/4ucfBrZi

    dump of $wpdb->get_results("show table status like '{$wpdb->posts}'"): http://pastebin.com/RG49pSNS

    note: engine was InnoDB, then i altered tables via PHPMyAdmin, purged yarpp and installed again: same result.

    *** EDIT ***: removing again all yarpp_ options after the new re-install solved

  9. pema
    Member
    Posted 1 year ago #

    i alter the wp_posts table to MyISAM and i even got the message that now i can consider titles and bodies but drop down option is still disable. I even did uninstall the plugin and reinstall it. Still option is disable.
    Is it because i am using it on localhost?

  10. pema
    Member
    Posted 1 year ago #

    i alter the wp_posts table to MyISAM and i even got the message that now i can consider titles and bodies but drop down option is still disable. I even did uninstall the plugin and reinstall it. Still option is disable.
    Is it because i am using it on localhost?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yet Another Related Posts Plugin (YARPP)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.