Support » Plugin: Jetpack by WordPress.com » Related Posts not working on my site.. use to.. now not?!

  • Resolved einstem

    (@einstem)


    All,

    Not sure why, but related posts are no longer displaying at the bottom of my posts on my site.

    Everything used to work a few weeks back. Not sure what has changed, but now they just don’t show-up at all.

    I just tried deactivating and reactivating the related posts option in WordPress Admin, but still nothing showing.

    My site is: http://www.EmailOverloadSolutions.com

    Just pick any post and scroll to the bottom and no related posts show..

    Any ideas of things I can check?

    Thanks.

    Michael

    https://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hey.. I just saw the list of know issues that there is an issue with Cloudflare’s Rocket Loader:

    CloudFlareโ€™s Rocket Loader is currently not compatible with Jetpack Likes, Site Stats, and other Jetpack features using Javascript. Youโ€™ll consequently need to disable this feature in your CloudFlare settings.

    I use this.. does it impact Related Posts as well??

    MIchael

    Nope.. that’s not it.. I disabled Cloudflare rocket loader and still no Related Posts on my site..

    Can some take a peek at my site and see if they can see something that would be blocking them..

    Thanks.

    Michael

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    I had a look at your site, and get the following error when trying to look at Related Posts for your most recent article:
    <!-- Page not cached by WP Super Cache. No closing HTML tag. Check your theme. -->

    That seems to be a common issue. You can read more about how to fix that problem here:
    https://wordpress.org/support/topic/plugin-wp-super-cache-error-no-closing-html-tag-not-caching?replies=5
    https://wordpress.org/support/topic/super-cache-causing-rss-error

    Once that error message is removed, Related Posts should start appearing on your site.

    OK.. Looks like WP Super Cache was definitely part of the issue.
    I messed around with the settings, but ended-up just giving up for now and turning it off. I don’t know what is going on with WP Super Cache, but it looks like that between Cloudflare (which I use), Jetpack Related Posts, and WP Super Cache things were conflicting somehow.

    So, the related posts are now showing-up on my site.

    However, what is strange is that I went to the “Jetpack Debug Center” to try to find problems, and that says:

    “There seems to be a problem with your siteโ€™s ability to communicate with Jetpack!”

    But when I check the “XMLRPC.PHP” page, it says:
    “XML-RPC server accepts POST requests only.”
    So that looks like that is ok.

    But when I click on the orange box to see the full error message, this is what the screen shows below.

    So, now I am not sure if it is really working properly or not.

    Can you look through the code below and give me some ideas as to what to look for?

    Thanks.

    Michael

    ——————————————-

    It looks like your site can not communicate properly with Jetpack.
    SELF:
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Wed, 21 Jan 2015 22:50:18 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [x-pingback] => https://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => {“error”:”Communication error”,”error_description”:”We were unable to make an XML-RPC request to your website. Please make sure that XML-RPC is turned on and that Jetpack is installed, activated and connected with your WordPress.com account.”}
    [response] => Array
    (
    [code] => 400
    [message] => Bad Request
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    Yes, it seems like your host blocked WordPress.com from communicating with your site via XML-RPC. Here is the message we get when trying to connect to your site:

    <html><head>
    <title>Your IP address was banned.</title>
    </head><body>
    <h1>Your IP address was temporarily banned.</h1>
    <p>You may have been banned for one of the following reasons:</p>
    <ul>
    <li>Failing to log into wordpress (wp-login) 10 times in 5 minutes (30 minute ban)</li>
    <li>POSTING to xmlrpc.php more than once in 60 seconds (2 hour ban)</li>
    </ul>
    <p>If you have a legitimate use for either of these cases please contact support.</p>
    </body></html>

    Could you contact your host and ask them to take a look?

    Thanks!

    Jeremy,
    Thank you so much for the fast response.
    I contacted my hosting provider, A2 Hosting, and this is their reply:
    —————————-
    Hello,

    To help increase server security and stability, a client IP address can be banned temporarily to prevent abuse. This can occur for any of the following reasons:

    -Failing to successfully log in to WordPress (the wp-login.php page) ten or more times in 5-minute period. This action results in a 30-minute ban.
    -Submitting more than one HTTP POST request in a 60-second period to the WordPress xmlrpc.php file. This action results in a 2-hour ban.

    Do you know which feature in Jetpack may have caused the issue, or what you or the site were doing prior the IP being blocked?

    We can disable the security feature for your domain but this will remove a layer of security that is used to protect that file and your login page from abuse.

    If you have any further questions, please feel free to contact us again.

    Thank you for choosing A2 Hosting,
    -David P
    ——–

    On my site, I use only the following Jetpack Plugins:
    “Related Posts”
    “Publicize”
    “Jetpack Comments’
    “Subscriptions”

    Is “Related Posts” the only one that uses XMLRPC?

    Could it be exceeding the “more then one posts in 60 second” limit that
    A2 hosting has?

    I am not crazy about disabling their security feature entirely since it protects my site from hack attacks.

    Any other ideas here?

    A2 Hosting is a pretty big and reputable hosting firm, so I would think that perhaps you could work with them to “whitelist” your IP address with them for XMLPRC perhaps?

    Thanks.

    Michael

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    -Submitting more than one HTTP POST request in a 60-second period to the WordPress xmlrpc.php file. This action results in a 2-hour ban.

    That would be what’s causing the issue. All 4 Jetpack modules in use on your site communicate with WordPress.com:

    • “Related Posts” communicates with WordPress.com to get a list of Related Posts for each post, and to send the new posts to WordPress.com to add them to the index.
    • “Publicize” and “Subscriptions ” contact WordPress.com when you publish a post, and WordPress.com then sends that post to your connected social networks.
    • “Jetpack Comments” contacts WordPress.com for each comment.

    I’d suggest deactivating that security feature, and use 2 plugins instead:

    I hope this helps.

    Jeremy,

    Thanks for the additional information.
    I will talk to my hosting provider about disabling this feature and implementing those two plugins instead (I already have “Limit Login Attempts” plugin on my site, so it would just be the additional XML-RPC plugin).

    However, I also want to see if there is a way to ‘white list’ the wordpress.com IP address from getting blocked.

    Is there a specific IP address you use for all of these communications I could provide to them and see if they could do this?

    Thanks.

    Michael

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    However, I also want to see if there is a way to ‘white list’ the wordpress.com IP address from getting blocked.

    Is there a specific IP address you use for all of these communications I could provide to them and see if they could do this?

    Our IP addresses change quite often, so I’m afraid that wouldn’t be a very good solution. It would only work for a little while.

    You might also experience issues with other legitimate services using XML-RPC, like the mobile apps or services like IFTTT.

    All in all, a blacklist seems like a better solution than a whitelist on the long run. That’s what plugins like BruteProtect do for you.

    Jeremy,

    Ok thanks for the response. Sounds like I need to disable this security on A2 hosting.

    I just checked, and I already have “Login Lockdown” plugin on my site, and I looked and it states it also protects against XMLRPC hacks, so I think I am probably ok with that one and may not need the extra “Disable XML-RPC Pingback” plugin, although I will look at it.

    A2 hosting also has a suggestion to also use a plugin called “Rename WP-Login.php” to change the URL to your WordPress login that sounds like it may help as well.

    Thanks for all the help.

    Regards,

    Michael

    Unfortunately, this still isn’t working.
    I had my hosting provider (A2 Hosting) disable their XML-RPC lock-out protocol, but when I go into Jetpack Debug, I see the following information below.

    Any ideas?

    Michael

    —-

    It looks like your site can not communicate properly with Jetpack.
    SELF:
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Sat, 24 Jan 2015 14:29:25 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [x-pingback] => https://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => {“error”:”Could not fetch your site data”,”error_description”:”We were unable to fetch the data from your Jetpack-powered site, the communication channel seems to be broken.”}
    [response] => Array
    (
    [code] => 400
    [message] => Bad Request
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    Unfortunately, this still isn’t working.
    I had my hosting provider (A2 Hosting) disable their XML-RPC lock-out protocol, but when I go into Jetpack Debug, I see the following information below.

    Any ideas?

    Michael

    —-

    It looks like your site can not communicate properly with Jetpack.
    SELF:
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Sat, 24 Jan 2015 14:29:25 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [x-pingback] => https://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => {“error”:”Could not fetch your site data”,”error_description”:”We were unable to fetch the data from your Jetpack-powered site, the communication channel seems to be broken.”}
    [response] => Array
    (
    [code] => 400
    [message] => Bad Request
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    Your site appears to be properly connected to WordPress.com now. I also see the Related Posts at the bottom of your posts. The error above is displayed because you’ve deactivated the Stats module. That’s consequently not an error you should be worried about ๐Ÿ™‚

    Jeremy,

    Thanks. Glad it is working now.

    I just activated the “Stats” module and that error message went away.

    That error message is a bit deceiving because it looks like you have a configuration error, but you just don’t have the “stats” module activated.

    You should look at changing that somehow.

    But thanks for all the help. I’m happy to be using the Jetpack modules correctly on my site.

    Thanks so much.

    Michael

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    That error message is a bit deceiving because it looks like you have a configuration error, but you just don’t have the “stats” module activated.

    You should look at changing that somehow.

    Yep, that’s on our radar.

    Thanks for the feedback!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Related Posts not working on my site.. use to.. now not?!’ is closed to new replies.