Support » Plugin: Jetpack by WordPress.com » Related Posts not working

  • Resolved Eli

    (@realact)


    Hello there,

    For some odd reason “Related Posts” isn’t working at our site, we use CloudFlare and have selected “No Query String” at the Catching Level option. we have also gone to Dashboard/Settings/Reading in WordPress and enabled related posts etc however it is still not working šŸ™

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Fotis

    (@fstat)

    Hi there,

    By running your site through the Jetpack Debugger is see an error that XML-RPC is turned off for your site. In order for Related Posts and other Jetpack features to work, this needs to be enabled. Please follow these instructions to enable XML-RPC on your site:

    https://codex.wordpress.org/XML-RPC_Support

    Eli

    (@realact)

    Hi there @fstat thanks for your reply.

    Yes, XML-RPC was off by the firewall plugin we use, I turned it back on, however when I go to https://deepinenespaƱol.org/xmlrpc.php it shows the following message:

    XML-RPC server accepts POST requests only.

    The related posts unfortunately are still not showing either.

    Plugin Support pmciano

    (@pmciano)

    @realact

    The related posts unfortunately are still not showing either.

    Can you give us more information about this issue?

    Was Related Posts working before, but it’s not now?

    Is it accurate to say that most of your posts are light on text and heavy on media?

    Also, does the problem persist if you temporarily disable all other plugins except for Jetpack, use a default theme, and re-index your site’s content?

    If you see intermittent issues only affecting certain posts, you can request a reindex of your site by clicking on Perform full sync at the bottom of your WordPress.com settings page.

    https://jetpack.com/support/related-posts/

    Once we get some feedback, we can take the next troubleshooting step in resolving your issue.

    Eli

    (@realact)

    Hi there @pmciano and @fstat it seems to be working now after enabling XML-RPC, it seems that it needed sometime to fetch the content.

    Thanks for the help.

    • This reply was modified 12 months ago by  Eli.
    • This reply was modified 12 months ago by  Eli.
    Plugin Support Fotis

    (@fstat)

    That’s great! Please let us know if you need help with anything else!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Related Posts not working’ is closed to new replies.