WordPress.org

Forums

Jetpack by WordPress.com
[resolved] Related Posts not showing up (3 posts)

  1. Kimberly Gypsy LoSavio
    Member
    Posted 1 year ago #

    my blog is at http://bloggingwithgypsy.com/blog/

    all blog posts are not showing the "related Posts" under the share buttons, but the code is there when I inspect elements. It's just empty.

    I have deactivated all plugins except JetPack and still nothing. I converted to Twenty Thirteen and Twenty Fourteen -- still no related posts.

    I did add the code to my functions.php to change it from 3 to 4 posts, and still nothing.

    I do not have all of JetPack's modules activated.

    This is incredibly frustrating as apparently I am the only one with this problem :( Because I've spent more time than I care to admit looking for a solution via Google. So here I am ...

    I tried the JetPack Debugger but for some reason that isn't working for me either. I just want the Related Posts module to work. HELP! Thanks :D

    https://wordpress.org/plugins/jetpack/

  2. Kimberly Gypsy LoSavio
    Member
    Posted 1 year ago #

    Problem has been solved! I cleaned up my htaccess file -- there were a couple things that could have caused it that I deleted. So I cannot tell you exactly what it was. But I am going to tell you all what I did in case someone else has an issue.

    First, I had to fix a totally different issue involving my theme and in the processes I deactivated ALL my plugins. I reactived a couple before I got to JetPack. When I reactivated and tried to log in to JetPack I got the dreaded xml_rpc-32601 ERROR. OMG what a nightmare. Anyhow, with the help of one link -- http://www.localpulse.net/technology/fix-jetpack-xml_rpc-32601-error-420/ -- I renamed my htaccess as specified to fix the error. When I named it back and on a hunch I thought I would see if Related Posts showed up. But it didn't.

    But I got an epiphany! I deleted everything in my htaccess except the wordpress code. When I did that, Related Posts showed up! HOLY CRAP Batman!!! I was so stoked!

    Then I added section by section what I would not get rid of for security and speed issues. The ONLY thing I did not keep was a ban IP code, all the denied IP addresses and a line of code I don't remember putting in, but may have been added by my hosting when I was tweaking via my cPanel. RewriteOptions inherit was at the top.

    So with all that gone, now my Related Posts is working slicker than snot!!! Woo Hoo!!!

    Moral of the story?? Check what's in your htaccess file. There may be something in there wreaking havok!

    Good Luck!!

  3. Y0mst3r
    Member
    Posted 1 year ago #

    How do I stop related posts and share buttons showing up in the twenty fourteen Ephemera in the side bar

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic