Support » Plugin: Jetpack by WordPress.com » Related Posts not showing

  • Resolved viajarapie

    (@viajarapie)


    Hi, my Related Posts are not showing at all. I’ve browsed through many other threads on the same issue and already tried several of the proposed solutions such as a re-sync and a disconnect/connect loop, also waiting a few hours after those.

    My site is viajarapie.info. I’ve tried ?relatedposts appended to a valid URL and I get an empty item list:

    {“version”:”20150408″,”show_thumbnails”:true,”show_date”:true,”show_context”:true,”layout”:”grid”,”headline”:”Relacionado”,”items”:[]}

    Hope you can help, thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    That’s interesting; we do have related posts indexed for your site, but they’re just not displayed on your site. I wonder if the Polylang plugin may be doing something that would impact the display of the posts.

    Could you try to deactivate that plugin and let me know how things go?

    Thanks!

    thanks for checking, I guess I can deactivate/reactivate Polylang with no loss of configuration or functionalities?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    I’m not familiar with the Polylang plugin, so it might be best to run your tests on a staging site first if you have one, just to be sure you won’t have to reconfigure the plugin once you activate it back.

    let me ask around then before trying. Polylang holds associations between equivalent content (posts, categories, media) in the different languages, losing that would be catastrophic. In the meantime, if you have any other idea, do let me know.

    I was advised to not deactivate Polylang, even if just in case. I don’t have a test environment either, any other idea of anything we could try?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Does your hosting provider offer the option to create staging environments for you? If not, it might be worth creating one thanks to a plugin, as explained here:
    https://www.elegantthemes.com/blog/tips-tricks/how-to-create-a-wordpress-staging-site

    I’m afraid I don’t really have any other recommendations. I tested Polylang on my end, and Related Posts disappeared from my site as soon as I assigned posts to Polylang’s default language I had just created. I think the problem is linked to Polylang, but I can’t really figure out what’s happening. It might be worth getting in touch with Polylang support as well, they might have heard about the issue already and may have a work-around. You could also try the snippet they published here and see if it helps:
    https://wordpress.org/support/topic/polylang-and-related-posts-plugin/#post-6921166

    Let me know how it goes.

    Once we know more, we should be able to work together with Polylang’s plugin author to find out how the 2 plugins conflict, and how to fix the issue.

    Hi, thanks for the feedback. It seems clear there’s a conflict between the two. The referred thread does not even appear as resolved, I wouldn’t expect much but I’ll try the suggested solution and see what happens.

    I installed the plugin offered by the Polylang author, then tried the suggested reindex of the related posts, clicked on the Debug option in Jetpack and got the following message:

    “It looks like your site can not communicate properly with Jetpack.”

    My site connection with Jetpack is apparently fine, everything (except the Related Posts, obviously) works fine. I tried a disconnect/reconnect cycle that was successful but clicking Debug had the same result.

    I didn’t see any “Reindex” option. I performed a full sync from my wordpress.com account, just in case.

    After all that, the problem stays the same, I get no Related Posts.

    Any ideas?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    clicked on the Debug option in Jetpack and got the following message:

    β€œIt looks like your site can not communicate properly with Jetpack.”

    That’s most likely a red herring, and caused by your custom site URL structure with the added /en/. You can safely ignore this.

    Too bad the problem is still the same, though. I’ve opened an issue on GitHub with my findings so far, and we’ll work on getting this fixed:
    https://github.com/Automattic/jetpack/issues/7203

    Until this gets fixed in Jetpack or in Polylang, I would recommend that you comment out this line in the Polylang plugin:
    https://github.com/polylang/polylang/blob/2.1.4/modules/plugins/plugins-compat.php#L46

    To comment out the line you can add // in front of add_filter.

    Commenting that line out made the Related Posts show up again! So far for all the posts I’ve tried, the Related Posts match the language of the holding post too.

    I’ll keep an eye on the issue anyway. Thanks a lot for all the help.

    Just to report that I have now spotted cases of Related Posts that don’t match the language of the related-to post. I guess this is after the commented-out line. No show-stopper but I’ll surely welcome a fix.

    Thanks again for taking care of it.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    We may be able to fix it in Polylang directly. Could you try to uncomment the line, and instead make the following change to Polylang?
    https://github.com/polylang/polylang/pull/135/files

    Let me know how it goes.

    VoilΓ‘, it works! So far it’s also chosen the right language every time. It looks like a solid solution, thanks a lot!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    I’m glad to hear that worked!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Related Posts not showing’ is closed to new replies.