Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Related Posts module is not working

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Lisa Schuyler

    (@lschuyler)

    Hi @airathalitov!

    WordPress.com is currently having trouble trying to sync your site’s contents through your Jetpack plugin, which is necessary in order to index your post contents to find a list of related posts. A 502 error code is being returned from your site.

    Can you check your PHP error logs to see if the error is recorded there?

    I suspect a security plugin or service on your server is blocking the communication between your site and WordPress.com.

    Let us know if we can help further!

    Thread Starter Airat HalitovšŸ”„

    (@airathalitov)

    I have 2 security plugins:
    * Wordfence Security
    * iThemes Security

    Error log:

    [error] 559#559: *33817 upstream prematurely closed connection while reading response header from upstream, client: IP, server: site.com, request: "POST /xmlrpc.php?for=jetpack&token=...
    [error] 589#589: *1639 upstream sent too big header while reading response header from upstream, client: IP, server: site.com, request: "POST /xmlrpc.php?for=jetpack HTTP/1.1", upstream: "https://IP:port/xmlrpc.php?for=jetpack", host: "site.com", referrer: "https://site.com/xmlrpc.php?for=jetpack"

    I think it’s iThemes Security plugin.

    Filter Long URL Strings (checked)
    Multiple Authentication Attempts per XML-RPC Request (Block)

    I have disabled this settings, but connection still reffused.
    How can I allow connection to wordpress.com?

    Thread Starter Airat HalitovšŸ”„

    (@airathalitov)

    It’s nginx errors

    Plugin Contributor Lisa Schuyler

    (@lschuyler)

    Hi @airathalito !

    I’ve you’ve tried disabling your other plugins and security settings and the problem persists, could you contact your hosting provider for assistance? It is possible they are blocking this communication between your Jetpack plugin and WordPress.com.

    Let us know how you make out!

    Thread Starter Airat HalitovšŸ”„

    (@airathalitov)

    @lschuyler

    I’he tried disbling security plugins, but it doesn’t help.
    Need to change nginx server settings.

    Thread Starter Airat HalitovšŸ”„

    (@airathalitov)

    @lschuyler
    Can you check connection now?

    Plugin Contributor Lisa Schuyler

    (@lschuyler)

    Hi @airathalitov!

    I’m still seeing 502 status code errors when Jetpack tries to sync information with your site.

    If that doesnā€™t help, could you add the following to your siteā€™s wp-config.php file? This will turn on the debug mode within WordPress.

    define( 'WP_DEBUG', true );
    
    if ( WP_DEBUG ) {
    
            @error_reporting( E_ALL );
            @ini_set( 'log_errors', true );
            @ini_set( 'log_errors_max_len', '0' );
    
            define( 'WP_DEBUG_LOG', true );
            define( 'WP_DEBUG_DISPLAY', false );
            define( 'CONCATENATE_SCRIPTS', false );
            define( 'SAVEQUERIES', true );
    
    }

    Once youā€™ve done so, try to activate Jetpack again and then check the wp-content/debug.log file for errors. You can paste the results here. You can then replace define('WP_DEBUG', true); by define('WP_DEBUG', false); in the code above.

    Thread Starter Airat HalitovšŸ”„

    (@airathalitov)

    @lschuyler

    My debug settings:

    /** Enable WP_DEBUG mode */
    define( 'WP_DEBUG', true );
    
    if ( WP_DEBUG ) {
        @error_reporting( E_ALL );
        @ini_set( 'log_errors', true );
        @ini_set( 'log_errors_max_len', '0' );
    
        define( 'WP_DEBUG_LOG', true );
        define( 'WP_DEBUG_DISPLAY', false );
        @ini_set( 'display_errors', 0 );
        define( 'CONCATENATE_SCRIPTS', false );
        define( 'SAVEQUERIES', true );
        define( 'SCRIPT_DEBUG', false );
    }

    I’ve tried disconnect and connect my site to jetpack.

    Log: jetpack-log.txt
    https://yadi.sk/i/RI–i6hv3HHRNB

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic šŸš€

    Thank you! It seems the 502 isn’t appearing in your logs. I wonder if it may happen before the request reaches your WordPress installation.

    Could you contact your hosting provider and ask them to check the security logs for your server, to make sure the Jetpack requests to your site’s XML-RPC file aren’t blocked before they reach your site?

    Let us know what you find!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic šŸš€

    Thank you! It seems the 502 error isn’t appearing in your logs. I wonder if it may happen before the request reaches your WordPress installation.

    Could you contact your hosting provider and ask them to check the security logs for your server, to make sure the Jetpack requests to your site’s XML-RPC file aren’t blocked before they reach your site?

    Let us know what you find!

    Thread Starter Airat HalitovšŸ”„

    (@airathalitov)

    I don’t know what the problem is.

    I decided to use yuzo-related-post plugin
    https://wordpress.org/plugins/yuzo-related-post/

    Thread Starter Airat HalitovšŸ”„

    (@airathalitov)

    Problem solved after update JetPack to v5.3
    Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Related Posts module is not working’ is closed to new replies.