Support » Plugin: All In One WP Security & Firewall » Related Posts Images

  • Resolved morio2

    (@morio2)


    Hello, I have been 1 week have one problem with plugin and i try to resolve it but i can’t, problem is that images on related posts not show on mobile, but in PC its fine.
    I have contacted theme support (Avada) and they told me that problem is because of All In One WP Security plugin, i have also try to use WordPress default themes like Twenty Fifteen and its have same problem, and i have deactivated all plugins expect All In One WP Security plugin and no fix, but if i deactivate All In One WP Security plugin then problem fixed.

    https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi do you have any of the following active Enable 6G Firewall Protection: or Enable legacy 5G Firewall Protection:?

    If you do can you deactivate these features and carry out another test?

    Hello mbrsolution and thank you for fast replay, yes i was Enable 6G Firewall Protection: or Enable legacy 5G Firewall Protection and i have deactivated them and clean plugins cache and browser cache and i have waiting 30 min, but problem not resolved.
    the only was to resolve this problem is by deactivated All In One WP Security & Firewall or disable all security featured but that makes me loose like 350 points, i even try myself to disable the featured one by one until my points become 20 point from 440 point what i was have with my settings, i don’t even know why is that, please look picture here…

    http://s31.postimg.org/kkhnl3c1n/13077298_1780891255479512_563179289_n_png.jpg

    Hello, i checked now on google chrome and its have same problem as mobile have, but in Mozilla Firefox its OK.
    My site http://www.wikiasema.fi/hello-world-5/

    Plugin Author wpsolutions

    (@wpsolutions)

    I just checked your site using my mobile device and the image shows up fine.
    Do you currently still have the aiowps plugin active?

    Hello and thanks for your replay, yes the aiowps plugin is active, and the problem still show up, i was have some issue with cloudflare service and them support just answered me and notify me about the same problem, so they also see that problem not just me, i use google chrome in mobile , please look at this 2 picture you will see the problem what cloudflare have found.

    http://s32.postimg.org/3tz5cze11/Problem_1.png

    http://s32.postimg.org/x7uvskgqt/Problem_2.png

    Plugin Author wpsolutions

    (@wpsolutions)

    Which firewall rules do you have enabled?
    Have you tried some tests by deactivating each firewall rule one at a time to see if one of them is causing this?

    Hi morio2,

    If you are having problems with images being blocked on mobile devices, try to turn off “Advanced Character String Filter” (under Firewall > Additional Firewall Rules) as it blocks any request with “@” sign in it. Often (and it seems to be your case too) retina-ready images that are served on mobile have “@2x” appended to the filename.

    Cheers,
    Česlav

    Hello and thanks for all support team for try to help,
    -I have try to turn off “Advanced Character String Filter” but its not fix the problem.
    -I deactivating each features rule one at a time until i deactivating all the features rule on the plugin except (File Permission and Admin Username) and Current Score of my Site become 35 from 415 what was my settings but that not fix the problem.
    -I clear plugins and browsers and DNS cache but that not fix the problem.
    -Disable all security features and firewall rules but that not fix the problem.
    -Deactivate the plugin it fix the problem, and if i activated back and restore my settings to 415 point and problem still fixed, but after 30 min or more problem comes back again, i have also update the plugin for today update but everything for my problem is same.

    Hi morio2,

    Please, deactivate “Advanced Character String Filter” and keep it deactivated. Then wait some time (30 mins or more) and check if the problem persists or not.

    I have no experience with CloudFlare, but from what you described (problem reappearing when firewall is activated, but only after some time), it seems that CloudFlare has some caching mechanism in place. So you have to give it some time to catch up when you disable/enable any firewall feature.

    Alternatively, you can ask CloudFlare support if they cache URL requests that are answered with “403 Forbidden” (and for how long).

    Cheers,
    Česlav

    Hello chesio,
    Really thank you so much for your active support.
    Yes you are right problem was because of “Advanced Character String Filter” and i should wait 1 to 2 hours to take effect and must clear cache many times, i have try this many times on last 12 hours and im 100% sure the reason was “Advanced Character String Filter” and now its resolved.
    Thank you again chesio.

    Plugin Author mra13

    (@mra13)

    The @ character has been removed from the “Advanced Character String Filter”. Thanks to @chesio.

    So this shouldn’t be an issue anymore.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Related Posts Images’ is closed to new replies.