Support » Plugin: Jetpack by WordPress.com » Related posts from Jetpack not working

  • I have the latest versions of WordPress and Jetpack.
    I have enabled the “Related Posts” functionality in Jetpack. I am able to see this from the edit/preview mode of my blog, but the actual pages is not showing any related posts.
    Could you please help?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have similar problem with Publicize at http://www.ilovecoffeesomuch.com/category/blog/ and main site too:

    – Twitter, FB and LinkedIn are connected with Publicize but none of the posts is published
    – Also social links are added to the end of the posts, but not shown online when post is published

    How to solve those things?

    I haven’t tried publicize yet. I am not familiar with the issue you mentioned.
    Problem is, their customer service team is very slow to respond to these queries. I have logged a request more than a month back, and it’s still open!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    I’m sorry to hear you’ve run into issues. Could you post your site URL here, so I can take a closer look? If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.com/contact-support/

    I am able to see this from the edit/preview mode of my blog, but the actual pages is not showing any related posts.

    Some Related Posts will indeed always indeed appear under Appearance > Customize when the Related Posts feature is enabled, but those are only examples so you can customize their appearance.

    I have logged a request more than a month back, and it’s still open!

    I can’t seem to find any other requests from you right now:
    https://wordpress.org/support/users/thetakeiteasychef/topics/

    Did you make that request from a different WordPress.org account, or did you contact us via email? If you contacted us via email, our reply most likely got caught in your inbox’s spam filter. We try to reply to everyone within 24 to 48h, whether you contact us here or via email, so if you’re still waiting after a month, our reply most likely got lost somewhere! πŸ™

    @lojze Your problem is quite different since it’s related to a different feature. Could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post

    Thank you!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    @lojze I see you also started a thread here:
    https://wordpress.org/support/topic/publicize-not-working-35/

    I’ll reply there. πŸ‘

    Hi Jeremy,
    Thank you very much for the detailed reply. I did hear back from the support team (I had contacted via email). I was advised to try the following workaround.

    “We had one of our developers take a look at your site and the Related Posts feature. They’ve suggested that you add a little code snippet that should help generate the Related Posts across your recipe posts too.

    First, if you don’t have one already, I’d recommend this Code Snippet plugin:
    https://wordpress.org/plugins/code-snippets/

    Then, add this line of code to a new snippet:

    add_filter( ‘jetpack_relatedposts_filter_post_type’, ‘allow_my_post_types’ );

    Then, see if the Related Posts appear. It may take 24 hours for the related posts to be generated.”

    I have added this snippet. Waiting to see if it works. Mine is a food blog, and almost all my posts are with the “Post Type” Recipe. And, this is my blog – https://www.thetakeiteasychef.com/

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    this is my blog – https://www.thetakeiteasychef.com/

    Excellent, thank you! I was able to find your email based on that URL. I’m also kind of hungry right now, some of those recipes look really delicious 😊

    Back to the problem at hand. You’re indeed in a special situation, because your site uses a custom post type, recipe, and posts in that Post Type weren’t available to WordPress.com before, and consequently weren’t indexed at all. No Related Posts were calculated for that Post Type.

    Luckily, it seems that my colleagues already helped you out with this. You can indeed use the rest_api_allowed_post_types filter to make a Custom Post Type (or a list of Post Types) available to WordPress.com, like so:

    function allow_my_post_types( $allowed_post_types ) {
        $allowed_post_types[] = 'recipe';
        return $allowed_post_types;
    }
    add_filter( 'rest_api_allowed_post_types', 'allow_my_post_types' );

    You can learn more about this filter here:
    https://developer.jetpack.com/hooks/rest_api_allowed_post_types/

    Once that filter is added to your site, you can then use the “Full Sync” button at the bottom of this page to force all your posts to be synchronized with WordPress.com:
    https://wordpress.com/settings/general/

    It seems you’ve done that already, and WordPress.com has now indexed all your recipes (57 of them apparently). It also generated Related Recipes for each one of them. You don’t need any additional filter for this to happen.

    Unfortunately, the related recipes still don’t appear. I wonder if the problem could be linked to your caching plugin, caching the related posts data for much longer than the usual 12 hours.

    We’ll take a closer look at this and get back to you soon!

    Thank you Jeremy! That’s a great feedback! All those recipes are easy to cook. You should try a few of them sometime πŸ™‚

    Thank you for the detailed analysis. Like you mentioned, I have done most of the obvious things. I’ll wait for your advice to progress further on this.

    Hi Jeremy,

    This is still open!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Related posts from Jetpack not working’ is closed to new replies.