WordPress.org

Forums

Jetpack by WordPress.com
[resolved] [closed] Related posts feature not working (31 posts)

  1. exist2014
    Member
    Posted 1 year ago #

    Hello,

    I have jetpack installed and I have activated the related post feature about a week back on my website bandra.info

    Somehow nothing shows up? Can you troubleshoot Sir.

    Manoj

    https://wordpress.org/plugins/jetpack/

  2. exist2014
    Member
    Posted 1 year ago #

    The website where it is not working is bandra.info

  3. Jamas
    Member
    Posted 1 year ago #

    I can see that the related posts header is getting inserted into your post but is hidden.

    On the Jetpack admin page click on the related posts to see if it shows indexing has completed.

    I have seen the same issue on a few sites running wp-minify plugin. From your header is doesn't look your running that but maybe you have another similar plugin installed. You can try the process of disabling all the other plugins and then turn them on one by one.

  4. exist2014
    Member
    Posted 1 year ago #

    Hi James

    I dont have wp-minify plugin on my site bandra.info I tried deactivating all plugins, except the Jetpack one, still the related posts wont show up, also I have a same duplicate site with the same plugin at powai.info where the related posts are showing correctly.

    My indexing status shows " Indexing request queued and waiting…" is this the reason why the related posts are not showing, this seems to have a bug, cause i have beed trying to do the indexing since last few days since i enabled the related posts.

  5. exist2014
    Member
    Posted 1 year ago #

    Hi James,

    Now it shows "Indexing posts (0%)"

  6. Emetreinta
    Member
    Posted 1 year ago #

    Hello.

    Same problem here. Related Posts not working.

    Indexing is completed. No wpminify plugin installed.

  7. exist2014
    Member
    Posted 1 year ago #

    Now it shows

    Indexing posts (9%)
    but still the related posts are not showing.

  8. Jamas
    Member
    Posted 1 year ago #

    Manjo

    Did you ever see it hit 100%?

    Jamas

  9. exist2014
    Member
    Posted 1 year ago #

    James,

    It at 21% now. Still no signs of related posts showing up on bandra.info

    Thanks.

  10. Biduido
    Member
    Posted 1 year ago #

    I have the same problem. I had YARPP and tried to move to Jetpack por related post, but doesn't works at all. I've deactivated it, and returned to YARPP, but I would like to use Jetpack and reduce the number of installed plugins. Of course, I indexed my site's post, with no better performance. jetpack simply doesn't work in this issue. My site is http://www.aikidoenlinea.com

  11. exist2014
    Member
    Posted 1 year ago #

    Hi Jamas,

    Looks like bandra info related posts is 100% indexed, still i dont see the application working.

    Any idea on how to trouble shoot the same?

    Manoj

  12. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    exist2014: I'm sorry for the delay in getting back to you. Do you still have this issue?

    Biduido: Could you please start your own thread, as per the Forum Welcome?

    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

  13. valuesourcer
    Member
    Posted 1 year ago #

    Hello, My case is different, my jet pack related posts are overlapping. I have no other related posts plugin. It's just the text are overlapping. please check this link:
    http://www.sheldonthinks.com/why-blue-chip-mining-stocks-make-less-sense/

  14. Jamas
    Member
    Posted 1 year ago #

    valuesourcer your issue looks to be an issue with the CSS. It looks like a conflict with your theme. The related posts is inheriting this from your theme.

    .entry p {
        margin-left: 20px;
        width: 560px;
    }

    It is the width part that is making the text extend outside the range. Possibly one of the Jetpack gang can take a look at the styles for related posts and protect against this sort of inheritance.

  15. valuesourcer
    Member
    Posted 1 year ago #

    Thanks Jamas, this is helpful. I will just remove the related posts feature for now... till I change themes.

  16. exist2014
    Member
    Posted 11 months ago #

    Hi Jamas,

    My issue is still not resolved, it been almost 5 months since i raised the ticket, or can you recommend any other similar plugin? my site is bandra.info

  17. Jamas
    Member
    Posted 11 months ago #

    exist2014

    Just checked your site. Looks like it is having some other issues at the moment. Took forever to load. I tried looking at the related posts directly by adding the ?relatedposts=1 to the end of the URL. Looks like the related post items are there but there is a warning being printed out about WP Super Cache not being setup correctly. That might explain the loading issues and the related posts issue. Here is the warning.

    WP Super Cache is installed but broken. The constant WPCACHEHOME must be set in the file wp-config.php and point at the WP Super Cache plugin directory.

  18. exist2014
    Member
    Posted 11 months ago #

    Super, now its working! Thanks a bunch!

  19. Jamas
    Member
    Posted 11 months ago #

    Great

    Quick recap for anyone finding this thread. If related posts feature isn't working do the following:

    1) Check that your posts have been indexed. Go to Jetpack->Debug (bottom of the Jetpack screen). Look for "Posts Indexed" which is good. If you don't see this then it can take some time to complete, try again later.

    2) Pick one of your posts that isn't showing related posts. Go to the single post view. Add the part in bold to the end of the url http://www.example.com/some-post/?related_posts=1 you should get something like this

    {"version":"20140611","show_thumbnails":true,"items":[{"id":647,"url":"http:\/\/www.jamas.net\/2013\/wordpress\/647\/","url_meta":{"origin":661,"position":0},"title":"WordPress 3.8","format":false,"excerpt":"WordPress 3.8 \u201cParker\u201d has arrived, bringing with it a new, slick, UI for WordPress. The WordPress admin UI has always been one of WordPress' big advantages over other CMS platforms.…","context":"In \"WordPress\"","img":{"src":"","width":0,"height":0}},{"id":621,"url":"http:\/\/www.jamas.net\/2013\/wordpress\/wordpress-3-7\/","url_meta":{"origin":661,"position":1},"title":"WordPress 3.7","format":false,"excerpt":"WordPress 3.7 \"Basie\" has arrived. This brings a big update for updates! Going forward updates to the WordPress core will automatically be done. This is sure to help with some…","context":"In \"WordPress\"","img":{"src":"","width":0,"height":0}},{"id":510,"url":"http:\/\/www.jamas.net\/2012\/wordpress\/wordpress-3-5\/","url_meta":{"origin":661,"position":2},"title":"WordPress 3.5","format":"aside","excerpt":"WordPress 3.5 \"Elvin\" has arrived. Featuring an even easier to use media upload environment, which from my quick test is really slick. Many of the people I help with WordPress…","context":"In \"WordPress\"","img":{"src":"","width":0,"height":0}}]}

    Look for any extra characters being printed in the output. For example a comment from a plugin, or some extra styling from css. If you see some extra data then you need to figure out what is causing it. Try default themes and turning off plugins until you find what is mangling the output.

    3) If the above output looks like what you are getting then see if there is any thing in your theme that might be hiding the related posts output. Try doing an inspect element in your favourite browser debugger (Firebug or Chrome Developer Tools). See if there is anything whacky in the css.

    Good luck!

  20. kylerbh
    Member
    Posted 11 months ago #

    Jamas I have had the same issue this is what I see when adding that to my post's URLs:
    {"version":"20140611","show_thumbnails":true,"items":[]}

    When I inspect the page I see this:

    <div id="jp-relatedposts" class="jp-relatedposts">
    
    </div>

    I have also disabled all plugins and themes to test for a conflict.

  21. kylerbh
    Member
    Posted 11 months ago #

    The website is: artofdharma.com

  22. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    @kylerbh: For what it's worth, the Related Posts module seems to be deactivated on your site. To troubleshoot this, could you please start your own thread, as per the Forum Welcome?

    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

  23. kylerbh
    Member
    Posted 11 months ago #

    @Richard Archambault: I was able to resolve the issue on my own. I was not fully satisfied with how the plugin decided what posts were related, so I decided to make a related posts section from scratch (not currently live). Thank you for your concern.

  24. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    @ kylerbh: we'd love to get your feedback on what you didn't like about the Related Posts, so if you have the time, please contact us with your thoughts! Thanks! http://jetpack.me/contact-support/

  25. Alex Sancho
    Member
    Posted 8 months ago #

    sadly I'm facing the same problem on a site that I'm building, related posts and like button loads on regular posts, but not on custom post types, any suggestion?

  26. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    @Alex Sancho Could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Could you also post your site URL there, so I can have a look?
    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

    Thank you!

  27. ThePaintedTiger
    Member
    Posted 7 months ago #

    Thanks for this thread, I thought the Related Post feature was not working at all, but through the troubleshooting, I see that it does work, but only in the single post view. Is it possible for Related Posts to show when you have the regular home view/ infinite scroll?

    Thank you for any help!

    http://thepaintedtiger.com/blog/

  28. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    I see that it does work, but only in the single post view. Is it possible for Related Posts to show when you have the regular home view/ infinite scroll?

    I'm afraid Related Posts were not designed to work this way. You'd have to use the Jetpack_RelatedPosts_Raw object (reference) to build your own Related Posts instance if you wanted to display Related Posts somewhere, like on the home page.

  29. ThePaintedTiger
    Member
    Posted 7 months ago #

    Ok, thank you for letting me know. I'm not up to building my own, so I'll just switch the posts to excerpts so people will click into the posts.

  30. nickkbisht
    Member
    Posted 7 months ago #

    Not working on my blog too... http://windowsphonewiki.com/

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic