Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Related post showing picture files instead of posts

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hello @misaka1,

    Thanks for reporting this, and sorry for the trouble!

    Can you tell me if you have published the images appearing in the Related Posts somewhere, like a single blog post with the only image included?

    Also, did you add any categories or tags you use for your blog posts to those images?

    There may be something else installed on the site that’s causing problems. Let’s go through the following troubleshooting steps to check for that:

    – Verify that all plugins are fully updated to the latest versions
    – Temporarily deactivate all plugins except Jetpack to see if there’s a plugin conflict. If the issue is resolved with all other plugins deactivated, you can reactivate plugins one by one to discover which plugin is causing the problem.
    – Clear your site cache

    Let me know what you find out, and we’ll take it from there. Thanks!

    Thread Starter misaka1

    (@misaka1)

    Hi @erania-pinnera ,

    The images were directly uploaded (attached) to the article I was writing at the time, so for example “Does-Nagatoro-Like-Senpai-s-1024×576-1” which is showing up in the Related is actually from this article. I can’t add categories nor tags to pictures, my theme doesn’t allow it.

    I troubleshooter it with the Health Check plugin and enabled only Jetpack & Caching plugin, and even tried w/o the Caching Plugin. There was no change. The picture file is still showing instead of a normal post in various articles.

    Plugin Support lastsplash (a11n)

    (@lastsplash)

    Hi @misaka1

    Thanks for providing additional information.

    I can see the issue in this screenshot:

    https://d.pr/i/UzJIBd

    It looks like the problem here is that your site is creating Attachment URLs for items in your Media Gallery. In turn, these are being indexed by Jetpack and factored into what we show in Related Post since the Attachment URLs are technically “posts”.

    I would recommend turning off Attachment URLs. There are some instructions on how to do that here:

    https://www.greengeeks.com/tutorials/set-wordpress-to-disable-attachment-pages-for-media/

    Once that is done, let us know and we can re-index your site.

    Thread Starter misaka1

    (@misaka1)

    Hi @lastsplash ,

    I understand what you are saying but I have always been using Yoast SEO with these settings.

    I don’t understand then why it’s still showing as an attachment URL.

    Plugin Support lastsplash (a11n)

    (@lastsplash)

    Hi @misaka1

    Thanks for the info.

    I am re-running a full sync of your site to update the index. In about an hour, please clear any site caches that you have and let us know if you still see the issue and we can take another look.

    Thread Starter misaka1

    (@misaka1)

    Hey @lastsplash ,

    I have deleted both the cache and minified js/css but I still see the picture files in both examples. 🙁

    Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hi @misaka1,

    Are you able to temporarily disable the Yoast settings and see if the issue gets fixed with the instructions my colleague shared earlier?

    I do have the same settings enabled on my test site, but I can’t reproduce the issue you’re having.

    If the above won’t work, we may want to investigate further, so let us know how it goes. Thanks!

    Thread Starter misaka1

    (@misaka1)

    Hi @erania-pinnera ,

    How can I disable the Yoast settings without deactivating the plugin? I did set Redirect attachment URLs to the attachment itself? to No and installed another plugin from the list that’s supposed to Redirect them upon activation, which I did, and I purged cache, but I still don’t see any change.

    deathlynotes

    (@deathlynotes)

    Hi @misaka1

    I tested your Related Posts links and images and they are working as expected.

    I’d like for you to try connecting in a fresh browser session, with no cookies — perhaps in an incognito browser window, if possible.

    Once you’ve opened the incognito browser session, test the related broken links.

    If that doesn’t work, can you please try a different browser than you usually use, and repeat the same steps above?

    Thanks so much!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.