WordPress.org

Forums

Shareaholic | share buttons, related posts, social analytics & more
[resolved] Related Content recommending Draft Pages (5 posts)

  1. cwendt01
    Member
    Posted 1 year ago #

    I don't recall this ever being a problem before, but I recently noticed that my posts are displayed recommended content that I have set to "Draft." Because of that, when people try to look at them, they get a 404 page because the content isn't published.

    I had at one time published the content temporarily for proofing purposes, but now have it set as a draft again. But even when it is live, I want it to be private.

    Is there any way to block certain content from showing up in Recommended Content?

    Thanks,
    - C.

    https://wordpress.org/plugins/sexybookmarks/

  2. Shareaholic
    Member
    Plugin Author

    Posted 1 year ago #

    cwendt01, yes, you can block certain content from showing up. First of all, I recommend upgrading to v7.2.0.0 of the plugin.

    http://wordpress.org/plugins/shareaholic/installation/

    After which you'll be able to:

    http://support.shareaholic.com/hc/en-us/articles/200471466-Excluding-pages-from-being-recommended

    ps - v7.2.0.0 automatically excludes private and password protected posts from being recommended. we'll add "drafts" to the auto exclude in the next version too!

  3. cwendt01
    Member
    Posted 1 year ago #

    Yep, on the latest version. I didn't realize there was settings on the Shareholic site itself I had to update to get those excluded! I figured you guys had a solution to something so simple. I was able to figure it out, thanks so much!

  4. Shareaholic
    Member
    Plugin Author

    Posted 1 year ago #

    Perfect! Glad you figured it out :)

    Each page/post edit screen also have a Shareaholic options box where you can mark a page/post for exclusion:

    http://support.shareaholic.com/hc/en-us/article_attachments/200262877/wordpress_exclusion.png

    When you save a post, Shareaholic is automatically notified to re-index that post.

  5. cwendt01
    Member
    Posted 1 year ago #

    Yeah I tried that and for some reason it didn't work for my pages. Maybe I should have cleared my or my site's cache or something. Oh well, it's working now so I'm happy. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.