Support » Plugin: Yet Another Related Posts Plugin (YARPP) » Related Algorithms

  • Resolved dimalifragis

    (@dimalifragis)


    Hello.

    The algorithms behind this plugin to find related is not good at all.

    For example: Two blog posts, with SAME tags. Only tags to be considered options (everything else is not consider) and Match = 5 (tried all from 0.1 to even 10), NO related posts are found.

    An other example: Same as above, with Tags Require at least one also NO related post found.

    If i’m not missing something, then it just doesn’t work right.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Michael Nelson

    (@mnelson4)

    Hi @dimalifragis, ya it sounds like there’s either a bug or something not quite configured correctly. We can help you get this sorted out! When I set to only consider tags, and use a threshold like .1, it brings up posts with the same tags (although when I use a relatively high threshold, like 5, it only shows the posts as related if they have at least 5 tags in common).

    So to figure out what’s going wrong it would be very helpful to see your configuration.

    To send us YARPP debug info,
    1. From WordPress admin dashboard, under “Settings” click “YARPP”
    2. Click “Help” in the top-right corner
    3. Click “Optional Data Collection” tab on the left
    4. Copy all the monospaced text
    Here’s a video: https://drive.google.com/uc?id=1Nw3IaXhs_7RTlUdzB5iTeBcymwcIJOby

    You can paste it in here or send it to jay at yarpp dot com.

    It might also be helpful if you could provide a link to two posts that SHOULD be related but aren’t. (And if your theme doesn’t show the tags, please tell us what the tags are.)

    We’ll get this figured out!

    Thread Starter dimalifragis

    (@dimalifragis)

    @mnelson4 I will try to do all what you suggested during the weekend.

    many thanks

    Thread Starter dimalifragis

    (@dimalifragis)

    Well after 2 months and after doing everything you suggested, no update.

    Plugin Author Michael Nelson

    (@mnelson4)

    Hi @dimalifragis sorry did you send us the debug information requested? If so it’s gotten lost or at least I haven’t seen it. Could you please post the debug info in here? (That will help others with similar issues too.) Here’s the instructions on how to send the debug info again (so you don’t have to hunt around for it)
    So to figure out what’s going wrong it would be very helpful to see your configuration.

    To send us YARPP debug info,
    1. From WordPress admin dashboard, under “Settings” click “YARPP”
    2. Click “Help” in the top-right corner
    3. Click “Optional Data Collection” tab on the left
    4. Copy all the monospaced text
    Here’s a video: https://drive.google.com/uc?id=1Nw3IaXhs_7RTlUdzB5iTeBcymwcIJOby
    5. Copy it into here

    Thread Starter dimalifragis

    (@dimalifragis)

    I did everything you requested and even got back a reply that you will be informed. And then nothing.

    Anyways, thanks for the reply, i have switched to something else.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.