Support » Plugin: Cision Block » Regulatory false and true not making a difference

  • Resolved MarcusFuto

    (@marcusfuto)


    Hello,

    I have used the shortcodes with both regulatory true and false but they show the same messages.

    I talked to cision and they confirm we are using IsRegulatory false and true correctly in the system. Might there have been somehtig that changed so it doesnt work with the shorcode?

    Is there another parameter that needs to be specified when using the regulatory parameter in the shortcode?

    I have placed it here:
    https://33trend.com/press-releases

    The shortcodes I am using are:
    1. For showing all: [cision-block]

    This seems to work.

    2. For showing only non-regulatory: [cision-block regulatory=false]

    This still shows all and not only the non-regulatory.

    Kind regards,

    Marcus

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author cyclonecode

    (@cyclonecode)

    Hello Marcus

    Will look into this and get back as soon as possible.

    Regards,
    Krister

    Thanks looking forward to your reply.

    Kind regards,
    Marcus

    Plugin Author cyclonecode

    (@cyclonecode)

    I have now looked on this and I believe this problem is because you have two shortcodes in the same page. The generated name for the cache entry is currently something like this _transient_cision_block_data_<PAGEID> so if you have two shortcodes in the same page/post then they will share the same cache entry, which of course will not work. I have created a new release 1.5.3 which should solve this as long as you specify and id for each block in the shortcode e.g:

         
    [cision-block id=first_block]
    [cision-block id=second_block regulatory=true]
    

    If this does not work try setting the cache time to 0 in order to turn it off and see if you then get a valid response.

    Regards,
    Krister

    Hello,

    Thanks for looking into this!

    I have tried on separate pages, with different id’s with true and false but I always get the same result.

    What might be causing this? Is there something else you could try?

    Thanks!

    Marcus

    Plugin Author cyclonecode

    (@cyclonecode)

    Hello again

    Would be great if you could send me your feed identifier so I can test this locally and figure out what is going on. Would also be great if you could copy and paste your current cision-block settings. If this works please send this information to cyclonecode@gmail.com and I will try to fix this.

    Regards,
    Krister

    Plugin Author cyclonecode

    (@cyclonecode)

    The issue here seemed to be that we wanted to display one block with only regulatory press releases and then another block with just non-regulatory press releases. This was at the time not support, you could either choose to display only regulatory items or all press releases. I have now added a setting called “View mode” where you can specify to display “All”, “Regulatory” or “Non-regulatory” items. This update is included in version 1.5.4 and includes a new shortcode argument view which also can be used for the same reason:

    
    view=1 // displays all items 
    view=2 // displays only regulatory items
    view=3 // displays only non-regulatory items
    

    Hello Krister,

    This feature was great! I am very thankful for your great support!

    Kind regards,

    Marcus

    Plugin Author cyclonecode

    (@cyclonecode)

    You are welcome. Just think I should have named this setting display instead of view haha =)

    Krister

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.