Support » Plugin: cformsII » Regular expression does not work anymore with AJAX

  • Resolved woltis

    (@woltis)


    Hello,
    since the latest update, the regular expressions for form fields do not work anymore when using AJAX.
    The expression is
    ^(.|\n){0,5600}$
    Without AJAX this form-validation still works.
    About a year ago there where was also a problem with regular expressions (see this thread here) but since the latest update everything worked well.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author bgermann

    (@bgermann)

    I cannot reproduce this issue. Maybe you got the same problem as in the linked thread, because you updated PHP and your settings were overwritten?

    You can post your form settings (Global Settings -> cforms Admin -> Produce debug output) if you want to help me investigate this.

    Thread Starter woltis

    (@woltis)

    I just opened the form and clicked on the setting of the text-field and noticed, that the regular expression has been split up. The original value ^(.|\n){0,5600}$ became a \n){0,5600}$| (pipe at the end!) in the regex-field and the fragment ^(. appeared in the field “Standard value”.

    I recreated the original expression and saved the value again. Called the field-settings again and everything appeared correctly.

    I tried to reproduce the split-error, but wasn’t able to. Now the form seems to work.

    • This reply was modified 3 years, 10 months ago by woltis.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Regular expression does not work anymore with AJAX’ is closed to new replies.