Support » Plugin: Elementor Page Builder » Regret using Elementor

  • Resolved rtwite

    (@rtwite)


    We had a theme upgrade by a developer and she used Elementor when she worked on the project. Left the plugin active in our new site and after using it for a couple of days, I liked how it worked. Unfortunately within about 5 days, it just suddenly stopped working and I got the “White Screen Of Death”. Yes, that is even mentioned in their support site. Tried everything to get it to work. Asked our IT people to help and they couldn’t figure it out either. The strange thing was that it worked just fine in an exact copy of the site in staging. Contacted Elementor support and it took them days to respond and they were not very helpful. After about 2 weeks if it not working, it suddenly started working, but only for about 2 days. Now it has stopped again. No changes to site, no new plugins. The problem is I used it on almost all our pages and now I can’t edit them correctly. Very frustrating process so don’t really recommend this plugin.

    I have tried everything we can think of. spent an hour with our site host (Siteground) and they were very helpful but just like our IT guys, elementor, and the host, they can’t replicate it on their end. Host says it must be our local network cache. I tried clearing our dns cache but still no change.

    Any help would truly be appreciated.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 16 through 23 (of 23 total)
  • LogoLogics

    (@logologics)

    Another thing that worries me is that you seem to combine Elementor, some Visual composer plugin and Gutenberg premium??

    I always recommend not to mix page builders because they have overlapping features that sooner or later will cause issues…

    rtwite

    (@rtwite)

    That makes sense but even when I deactivate all the plugins except for Elementor, it still doesn’t work. I would assume that means there isn’t a plugin conflict if they are all deactivated. When I try using it in Twenty Nineteen theme, it seems to work will all the plugins activated.

    rtwite

    (@rtwite)

    Not sure how to disable custom code.

    cavalierlife

    (@cavalierlife)

    If it works with a different theme, you’ve narrowed the problem down considerably. Check and temporarily remove all your custom code in your child theme (if any), check all of GP’s options, and get in touch with Tom and his team at GeneratePress. They are wizards with their theme and can probably spot the issue quickly.

    LogoLogics

    (@logologics)

    I see yes, and after you deactivated all plugins you did clear ALL cache? In WordPress, browser and Cloudflare?

    I have had that many times, thinking it still did not work, and yet it was simply some cache showing me the “not yet fixed state”.

    CUSTOM CODE

    Well, I see you have headers and footers plugin to add custom code.
    In the settings of that plugin you can simply uncheck code to deactivate and activate it again too.

    If there is a child theme of Generate Press, there could be some custom code in there as well. Is the web designer out of reach or can you ask him or her about that?

    • This reply was modified 2 months ago by  LogoLogics.
    LogoLogics

    (@logologics)

    Ah, I see there is in fact a child theme active:

    == Theme ==
    Name: GeneratePress Child
    Version: 0.1
    Author: Tom Usborne
    Child Theme: Yes
    Parent Theme Name: GeneratePress
    Parent Theme Version: 2.3.2
    Parent Theme Author: Tom Usborne

    rtwite

    (@rtwite)

    Ok, here is the update on this. After hours of time trying to fix, IT support giving up, numerous chats with host, dozens of emails from Elementor, I logged in yesterday and all of a sudden, Elementor started working. This happened before and after a couple of days it quit. Am considering changing hosts just in case it is a server issue.

    LogoLogics

    (@logologics)

    Very strange indeed.
    Unfortunately it worked before for a while so fingers crossed!

    Siteground has a good reputation and that staging is also on their servers so there must be some difference on server or plugins between that staging and the live site.

    Let’s hope it will be smooth sailing from now on!

Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.