Support » Plugin: RSVP and Event Management Plugin » registration not working / how to debug?

  • Resolved cwrichardson

    (@cwrichardson)


    Hi,

    First — great plugin! Second, _mostly_ seems to be working great. That said, I seem to be having a strange symptom, and my question is really about how to diagnose is further so I can report the actual problem.

    I’m trying to RSVP for one of our guests. The process seems to go fine, and the confirmation page comes up with a success message and a passcode. However, they never actually appear in the database, nor are any emails sent. Note, I’ve had several guests successfully register today, so this seems to only be a problem for me (as the site admin). I’ve tried with different browsers (Chrome and Safari), have tried both logged in and logged out, have tried submitting through the form on the website and through the “add guest” page. Same result in all cases — success indicated, but no actual success.

    I’m not _too_ worried about it as, as I said, it seems to be working for others. However, I would like to track it down, just in case I am losing registrations 🙁

    This is the free version of RSVP 2.6.3 on WordPress 4.9.10.

    As this is our wedding website, and it’s set to Allow Open Registration, I’m hesitant to put the URL here, but I can if it becomes necessary.

    Since it broadly seems to be working for others, my guess is that either something funny is happening with cookies, or something funny is happening with the cache (I’m using W3 Total Cache on Amazon S3).

    So … is there a “debug” flag I can turn on? Log files I can look in? Nothing unusual at all appears to be showing up in the httpd logs (e.g., the entries look like this: 10.0.202.48 – – [13/May/2019:05:24:53 +0000] “POST /rsvp/ HTTP/1.1” 200 6802 “-” “Amazon CloudFront”).

    Any place to start looking would be much appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author mdedev

    (@mdedev)

    Hi @cwrichardson,

    Sorry that you are running into problems. I have two general thoughts on this for debugging purposes.
    1) If you can disable some plugins like W3 Total Cache and see if it goes away that would be appreciated. Even if it is just to disable the plugins while you run through it and test it. Also, depending on the theme it is worth a shot to use a stock theme just for a quick test. Since it sounds like you are receiving RSVPs though that might be tough.
    2) I would look in the PHP error logs for any SQL errors and/or any PHP exceptions. The plugin makes inserts into the database and if we are lucky an error is being thrown that will shine the light on the issue. You might also want to look at the MySQL error log to see if that has anything useful.

    Feel free to shoot me an email at mikede@mde-dev.com and we can try to debug this together.

    Thanks,
    Mike

    Hey Mike,

    Thanks for getting back to me! I’ll send a similar note by email, so we can go back and forth if necessary, but, I have an update:

    Upon further investigation, it appears to be completely replicable. The problem has something to do with text in the comments box. The system indicates success, but silently fails, if there are certain characters in the comment box. An emoji smiley will demonstrate the problem:

    😊

    Unfortunately, I’m not seeing any errors in either the PHP or database logs, but I guess this discovery does make it more urgent — hopefully I don’t have a bunch of people showing up to my wedding that I don’t know about, because they put smiley faces in their comments 🙂

    Plugin Author mdedev

    (@mdedev)

    Hi @cwrichardson,

    I have not run across this before. More than likely you will need to change the encoding for the table to support handling of emojis. Here is a good link explaining this – https://stackoverflow.com/questions/39463134/how-to-store-emoji-character-in-mysql-database

    -Mike

    Hmm. This didn’t seem likely, as the utf8mb4 upgrade came in WordPress 4.2, and this site is only about 5 months, but, just to double check, I

    1. Put an emoji in a post comment (it worked fine)
    2. Checked the character encoding for tables in the database

    This was weird. The appropriate WordPress tables are utf8mb4:

    mysql> SHOW FULL COLUMNS FROM wp_comments WHERE Field="comment_content";
    | Field           | Type | Collation              |
    | comment_content | text | utf8mb4_unicode_520_ci |

    But, indeed, the RSVP plugin is set to regular utf8:

    mysql> SHOW FULL COLUMNS FROM wp_attendees WHERE Field="note";
    | Field | Type | Collation       |
    | note  | text | utf8_unicode_ci |

    So … I changed it:

    mysql> ALTER TABLE wp_attendees MODIFY note text CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_520_ci;

    Woohoo! Problem solved!

    So, thanks for the help, and all good at my end! But, why would it have created it that way in the first place?

    Also, I just saw your email. All good!

    Plugin Author mdedev

    (@mdedev)

    I just released 2.6.4 which also has this DB schema change as well. Thanks for your help in figuring out what needs to be fixed.

    -Mike

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘registration not working / how to debug?’ is closed to new replies.