Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » Registration form refresh without registering new user

  • The registration form used to work until recently.
    Nothing changed on the website, but now users who try to register only see the registration page refresh and their registration doesn’t go through, with no error messages displaying on the page.

    In addition to the fact that nothing changed on the website, I have already performed a conflict test, getting the same behavior with UM plugin being the only active plugin and the TwentySeventeen theme.

    I am going to roll back to a previous version to see if that fix the problem.

    Please advise.
    Luigi.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter luigipulcini

    (@luigipulcini)

    I can confirm that rolling back to version 2.0.12 fixed the problem.

    After deleting version 2.0.13 and installing 2.0.12 the registration form started to work again. When I updated the plugin to version 2.0.13, initially the registration form still worked, but after reloading the page with re-caching, the refreshing registration form problem occurred again.
    Since I did not get this problem right away after updating to version 2.0.13, but only after I re-cached the page, I suspect the problem could be coming from a javascript.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @luigipulcini,

    Can you please try to exclude Ultimate member pages from the cache and see if it solves your issue.

    Regards.

    @luigipulcini

    I have had the exact same issue and had to roll back too.

    Other javascript related items have broken too with that update. Might be a JS conflict of some sort.

    Thread Starter luigipulcini

    (@luigipulcini)

    Can you please try to exclude Ultimate member pages from the cache and see if it solves your issue.

    While performing my tests, rolling back to version 2.0.12, updating to version 2.0.13 again and rolling back to 2.0.12 once again, all the caching features of my website were temporarily deactivated and the whole cache purged. That included both SiteGround SuperCache and CloudFlare (development mode).

    I am having the same issue. Reverting back to 2.0.12 didn’t help me though. @luigipulcini, when you reverted back, did you delete all of the data or just the plugin?

    Thread Starter luigipulcini

    (@luigipulcini)

    No, @jfahey, I did not have to delete the settings.
    I simply deactivated then deleted the plugin (v2.0.13) and immediately installed v2.0.12. Of course, I also purged all the cached files from both the server and the browser. In my case, on SiteGround, I had to purge both the SuperCacher and CloudFlare. After that, the registration form started working as expected, again.

    Since I updated the plugin to version 2.0.13 after rolling back to version 2.0.12 and the registration form stopped working again (so that I had to roll back to version 2.0.12 once more), I am pretty sure there must be something hidden there.

    I hope this helps.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Registration form refresh without registering new user’ is closed to new replies.