Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » Registration Form doesn’t work sometimes

  • Resolved pwred

    (@pwred)


    Hey, I think I have a very strange issue.
    As I read before, there are other users who had a problem with the registration form. I also have had this problem, that my page just reloads when somebody tries to register. I tried registering with another plugin and it worked. The crazy thing about this is: After creating a new user with the other plugin, Ultimate member worked too! When I delete the user I’ve created with the other plugin, the UM Registration form stopped working(??). Also after a few hours, it stops working automatically. Today it worked all night long, but when I tried in the morning, just about half an hour after the last registration, it didn’t work. After creating an account with the other plugin, it worked again.
    I never had problems with the registration form before, I am just experiencing this for about 2 days now.

    The only thing I recognized is, that the two plugins user different time zones. The other plugin uses my timezone, and UM another one (about 2 hours delayed). So when I create an account with the other plugin, and then one with UM, the one created with UM was created before the other user.

    I just don’t understand this logic. I hope that you may can help me. Thanks so much!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @pwred

    I suspect that there’s a server-side issue here. Could you please tell us if your site is in shared hosting? Could you please check if there are any error logs related to the registration form? You can ask your hosting provider to assist you with retrieving the error logs. Paste it here when you have the logs so we can review it. Feel free to re-open this thread if there’s any question that may come up.

    Regards,

    Thread Starter pwred

    (@pwred)

    Hello @champsupertramp
    Thank you very much for your answer!
    Yes, I am in shared hosting. The provider made a few changes today, because the website didn’t work at all. No everything seems to work, but I’ll write them and you again, when it doesn’t work.

    Thank you so much!

    Thread Starter pwred

    (@pwred)

    Hey @champsupertramp
    Unfortunately the error occurred again. Where do I find these logs?

    Thread Starter pwred

    (@pwred)

    @champsupertramp I have a log folder, but I really don’t know where I could find the registration logs.

    Thread Starter pwred

    (@pwred)

    @champsupertramp sorry for writing again, but do you mean this?

    [13-Oct-2020 18:00:30 UTC] PHP Notice:  register_rest_route was called <strong>incorrectly</strong>. The REST API route definition for <code>shariff/v1/share_counts</code> is missing the required <code>permission_callback</code> argument. For REST API routes that are intended to be public, use <code>__return_true</code> as the permission callback. Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.5.0.) in /homepages/19/d835565643/htdocs/app835565819/wp-includes/functions.php on line 5225
    [13-Oct-2020 18:01:12 UTC] PHP Notice:  register_rest_route was called <strong>incorrectly</strong>. The REST API route definition for <code>shariff/v1/share_counts</code> is missing the required <code>permission_callback</code> argument. For REST API routes that are intended to be public, use <code>__return_true</code> as the permission callback. Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.5.0.) in /homepages/19/d835565643/htdocs/app835565819/wp-includes/functions.php on line 5225
    [13-Oct-2020 18:01:27 UTC] PHP Notice:  register_rest_route was called <strong>incorrectly</strong>. The REST API route definition for <code>shariff/v1/share_counts</code> is missing the required <code>permission_callback</code> argument. For REST API routes that are intended to be public, use <code>__return_true</code> as the permission callback. Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.5.0.) in /homepages/19/d835565643/htdocs/app835565819/wp-includes/functions.php on line 5225
    [13-Oct-2020 18:03:27 UTC] PHP Notice:  register_rest_route was called <strong>incorrectly</strong>. The REST API route definition for <code>shariff/v1/share_counts</code> is missing the required <code>permission_callback</code> argument. For REST API routes that are intended to be public, use <code>__return_true</code> as the permission callback. Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.5.0.) in /homepages/19/d835565643/htdocs/app835565819/wp-includes/functions.php on line 5225
    [13-Oct-2020 18:03:32 UTC] PHP Fatal error:  Uncaught TypeError: Argument 1 passed to UR_User_Approval::check_status_on_login() must be an instance of WP_User, instance of WP_Error given, called in /homepages/19/d835565643/htdocs/app835565819/wp-includes/class-wp-hook.php on line 287 and defined in /homepages/19/d835565643/htdocs/app835565819/wp-content/plugins/user-registration/includes/class-ur-user-approval.php:170
    Stack trace:
    #0 /homepages/19/d835565643/htdocs/app835565819/wp-includes/class-wp-hook.php(287): UR_User_Approval->check_status_on_login(Object(WP_Error), 'arirang777')
    #1 /homepages/19/d835565643/htdocs/app835565819/wp-includes/plugin.php(206): WP_Hook->apply_filters(Object(WP_Error), Array)
    #2 /homepages/19/d835565643/htdocs/app835565819/wp-content/plugins/ultimate-member/includes/core/um-actions-login.php(71): apply_filters('wp_authenticate...', Object(WP_Error), 'arirang777')
    #3 /homepages/19/d835565643/htdocs/app835565819/wp-includes/class-wp-hook.php(287): um_submit_form_errors_hook_login(Array)
    #4 /homepages/19/d835565643/htdocs/app in /homepages/19/d835565643/htdocs/app835565819/wp-content/plugins/user-registration/includes/class-ur-user-approval.php on line 170
    [13-Oct-2020 18:03:35 UTC] PHP Notice:  register_rest_route was called <strong>incorrectly</strong>. The REST API route definition for <code>shariff/v1/share_counts</code> is missing the required <code>permission_callback</code> argument. For REST API routes that are intended to be public, use <code>__return_true</code> as the permission callback. Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.5.0.) in /homepages/19/d835565643/htdocs/app835565819/wp-includes/functions.php on line 5225
    [13-Oct-2020 18:04:40 UTC] PHP Notice:  register_rest_route was called <strong>incorrectly</strong>. The REST API route definition for <code>shariff/v1/share_counts</code> is missing the required <code>permission_callback</code> argument. For REST API routes that are intended to be public, use <code>__return_true</code> as the permission callback. Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.5.0.) in /homepages/19/d835565643/htdocs/app835565819/wp-includes/functions.php on line 5225
    [13-Oct-2020 18:04:56 UTC] PHP Notice:  register_rest_route was called <strong>incorrectly</strong>. The REST API route definition for <code>shariff/v1/share_counts</code> is missing the required <code>permission_callback</code> argument. For REST API routes that are intended to be public, use <code>__return_true</code> as the permission callback. Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.5.0.) in /homepages/19/d835565643/htdocs/app835565819/wp-includes/functions.php on line 5225
    
    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @pwred

    Could you please try adding an Email Address field to your Register form and see if the issue still occurs?

    Regards,

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @pwred …This thread has been inactive for a while so we’re going to go ahead and mark it Resolved.

    Please feel free to re-open this thread if any other questions come up and we’d be happy to help. 🙂

    Regards,

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Registration Form doesn’t work sometimes’ is closed to new replies.