WordPress.org

Support

Support » How-To and Troubleshooting » Registration email shows incorrect “From:”

Registration email shows incorrect “From:”

  • I have a site based around community blogging, anyone can join and post.

    But when people sign up the “From” details in the registration email shows my hosts address (root@host299.ipowerweb.com) and not an email that I can nominate (registration@cafegeek.com).

    The only information I could find was http://trac.wordpress.org/ticket/1164

    Does anybody have any ideas please.

    thank you
    rob

Viewing 6 replies - 1 through 6 (of 6 total)
  • All,

    I’m sorry to bump, but I really need help here.

    From what I understand the “From” email address that people see when they register as users on my blog is the admin email in my blog options.

    I have set and reset this several times, checked the DB (it’s in there) and yet my hosts email (root@host299.ipowerweb.com) still appears as the “From” address.

    Is there a way I can hard code this into the PHP?

    Maybe a WordPress Guru has the answer?

    What version of WordPress?

    Also might want to look at this: http://wordpress.org/support/topic.php?id=24981

    If I am not mistaken (which I often am), I think this has something to do with how your host set up the php mail function.

    hmmm,

    I tried the changes as set out by MichaelH but still no joy. I will contact my host to see what happens.

    I am officially an idiot. The solution offerred by MichaelH worked. But only after I removed the “+” from the code before “From:”.

    Like a bumbling newbie coder I just assumed that it was part of the PHP syntax and left it in. It wasn’t unitl I actually played with code the code that I realised I was a fool.

    Thanks to all for your help and sugegstions…. Now go and join cafegeek.com and review some cafes.


    function wp_mail($to, $subject, $message, $headers = '') {
    if( $headers == '' ) {
    $headers = "MIME-Version: 1.0n" .
    + "From: " . get_settings('admin_email') . "n";
    "Content-Type: text/plain; charset=\"" . get_settings('blog_charset') . "\"n";
    }

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Registration email shows incorrect “From:”’ is closed to new replies.
Skip to toolbar