WordPress.org

Support

Support » How-To and Troubleshooting » Registration email not coming through.

Registration email not coming through.

  • Hello.

    I am running WordPress 2.0.5. Users, when registering on my blog are told they will receive an email with their password.

    This password never comes. Spam folders are checked, too. Nothing. I’ve confirmed this myself. I can manually assign new passwords through my control panel, but that’s a huge pain in the ass.

    My server fully supports WordPress’ requirements and the PHP email function is enabled. I receive an email from my blog on my personal account each time a new visitor registers, so it’s not a problem on the server.

    I’ve searched here for a potential answer. A lot of them went unanswered.

    These did not help me:
    http://wordpress.org/support/topic/98787?replies=3
    http://wordpress.org/support/topic/75620?replies=10

    Please help.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thanks for the help.

    First I’ve seen of this thread. There’s a couple zillion of you and a handful of us.

    Anything in the mail server logs? Does the email get sent? Is there some sort of error?

    Are you hosting your own server from your house? If so, your ip is probably part of a blacklist. There isn’t much you can do, except contact your isp and probably pay for a business account.

    There is one other option. There is a swift-smtp plugin for wordpress that allows you to configure your emailing system to use a third party smtp server, like gmail or comcast pop mail.

    It takes over the emailing system and routes all messages through the smtp server you specify.

    Ok all, I may have the answer that will help at least some of you. I had the same issue with the registration email never getting to our users, so I contacted our host and ran the scenario past them. I received a fast reply and the instructions that would hopefully take care of the problem. “It worked perfectly!” Here’s a copy of the message:
    ________________________________

    Hello,

    The server housing your account currently has phpmail() disabled. This is how WordPress tries to send mail. Below are instructions for a plugin you can install/configure to route around this for WordPress.

    For WordPress 2.1 and up:

    Please download the plugin from http://v-nessa.net/imh_files/wp-phpmailer.zip and follow the instructions below.

    For WordPress versions below 2.1:

    1) Download the plugin from http://www.v-nessa.net/imh_files/ShiftThis_SMTP-Wordpress_Plugin_v092beta.zip

    2) Once the file is downloaded, unzip the archive and upload the shiftthis-smtp folder into the …/wp-content/plugins directory of the WordPress installation.

    3) Next, log in as the administrator (usually yourdomain.com/your_path_to_wp_installation/wp-admin

    4) Go to Plugins and select ShiftThis SMTP Swift Emailer, and Activate the plugin

    5) Go back up to Options ~> SMTP and modify the email settings:

    Server Address: localhost
    Username: outgoing server account name (must be a complete email address you create in cpanel)
    Password: outgoing server account password (password for above email address)
    Use SSL or TLS? No
    Port: 25 (Default SMTP Port)

    You can set the outgoing server to use SSL, but as with any other email client, you must use port 465

    _______________________________

    Like I said, the plugin did the trick for me (I’m using v2.3.1, so I had to do a little extra figuring on settings) . Hope it helps you too. If it does, hopefully someone will add the link from this post to some of the many other messages that seem to say basically the same thing.

    Cheers,
    Jeff

    I’m having a similar problem

    Intersting – and I’ll try it.

    My problem however is that only users who are on SBCGLOBAL are having this problem.

    theapparatus

    @theapparatus

    Member

    You maybe blacklisted. Posting a link to your blog may be helpful.

    You mean I may be blacklisted at SBC?

    whoa.

    Never thought of that. I’ll have to check on that grrrrrr.

    thanks

    theapparatus

    @theapparatus

    Member

    It may not be your fault. It may be due to the actions of others on the box you sit on, the company you lease space from, etc.

    This is definately an issue with SBC Global.

    None of my SBC users receive their passwords back – confirmed. All other users are fine.

    My Host says that they have no other SBC reported email issues.

    The FROM field in the return email looks like this:

    domain-name.com

    unfortunately there is a hyphen in my domain name.

    Either the hyphen or the fact that it’s a domain name may be screwing up SBC. I’d like to change this to say anything but xxx.com

    I changed a line in plugable.php but that didn’t do it.

    Any ideas where I can change this?

    jtilton’s solution worked for me! thanks!

    I’m having the same problems as everyone else apparently and I am trying out jtilton’s fix. I can install the plug-in ok, activate it, and then go into the options, but it seems my options are different that what he has listed…

    I can choose to either
    A) Sendmail via mail() (Default WordPress mail handler)
    B) SMTP via wpPHPMailer

    I’m assuming I pick B, then here are the options I’m not sure what to use…

    SMTP mail server: The example they give here is smtp1.example.com
    Port: Default is set at 25
    SMTP server requires authentication?: (If checked, specify authentication settings below)
    SMTP mail username:
    SMTP mail password:
    Wordwrap length: Default is set at 60
    Use hardcoded from values?: Default is unchecked
    Hardcoded from e-mail:
    Hardcoded from name:

    Any help here would be appreciated, I really need to get this up and running.

    If anyone knows how to set up my web server as a mail server since i’m running Ubuntu Linux 7.10, that would be even better than relying on a plug-in.

    Thanks,

    Same problem as Vivid here, anyone?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Registration email not coming through.’ is closed to new replies.