Support » Plugin: User Meta - User Profile Builder and User management plugin » Registration confirmed but not executed

  • Resolved klaus_hh

    (@klaus_hh)


    Hi there,

    I have a database with around 200 users and I am trying to add a certain one. I can fill the User Meta registration form or add the record in the backend: both ways I receive a confirmation that a user record has been added but I cannot see and find that new record, not even in table wp_users

    I think I used that user name and email before but deleted them again. Anyway I cannot find user name, first name or email in the database in table wp_user

    Any idea how I can fix that or how I can clean old registration stuff that maybe blocks a new registration?

    By the way: in the admin notification fields user name and email are blank.

    Thanks for help

    Klaus

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Sourov Amin

    (@sourov)

    Hello,

    What it is: you can’t add a new user with specific details or you can’t add any new user at all?

    Thanks.

    klaus_hh

    (@klaus_hh)

    I can add users, but it fails when I try to add a certain user, whose user name or email may have been used before (but does not appear in the user list or anywhere else).
    Thanks

    Plugin Contributor Sourov Amin

    (@sourov)

    Can you deactivate this User Meta plugin for a moment and try to add that specific user from the backend just to be sure whether the plugin causing any problem in this regard or not.

    klaus_hh

    (@klaus_hh)

    Hi,

    I followed your advice.
    After deactivation I could create the user.
    Then deleted it, activated the plugin, created the user again (from the backend) – all fine.
    Then I deleted the user again and created the user from the frontend (on a different browser, not logged in): at the end I got the message to wait for admin approval. But in the backend user list there was no such user. Irritating…
    Then I once again tried to create the user from admin backend: saw “Created new user” but no “Edit user” link was added and user did not show up in the user directory.
    I tried again, this time not with a “weak” password but with the one generated by WP and I left the “Website” field blank (the user has a very long url with 3 or 4 subfolders..). This time the user was created and showed up, could be edited.

    Irritation remains but I leave it at that and hope that future users can be created without problem.

    Still not working (in backend and frontend): I can fill in and save https://www.cityofadelaide.com.au/explore-the-city/visit-adelaide/visitor-information but cannot add another subfolder.
    Is there a restriction in WordPress?

    Thanks and regards
    Klaus

    Plugin Contributor Sourov Amin

    (@sourov)

    Okay, It’s not a problem produced by this plugin at all. By default, WordPress user database supports highest of 100 characters for Website field. Also, it’s not a problem of subfolder in URL, if you exceed 100 characters in the Website field the whole process doesn’t save any data to the user database but it shows the success message as there may be some flaws in WordPress Website field’s validation itself.

    You can fix this in front-end registration with the User Meta plugin. Just put a higer value of Max Char like 500 from Website field’s Advanced tab.

    Interesting, thanks.

    It is a URL of 103 characters.

    Now I tried with a maximum of characters of 200 and 300. But in both cases saving failed: when I refresh the frontend profile form or look in the backend I see the old (shortened) URL.

    Anything else to do?

    Klaus

    Plugin Contributor Sourov Amin

    (@sourov)

    Actually, you have to change the database structure in order to use WordPress default Website field. But you can ignore the field and create a new URL field from the Extra Fields and make it shared. Add the field both in frontend-backend, and hide the actual website field from the backend from User Meta >> Settings >> Backend Profile. That should do your job.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.