WordPress.org

Forums

Front-End Only Users
[resolved] Registration (6 posts)

  1. eznetworks
    Member
    Posted 10 months ago #

    I can not register (front or via admin). 'Warning: Illegal string offset Message in /home/enetwo5/public_html/deagnetworks.com/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Register_Form.php on line 37'

    Am I missing anything?

    https://wordpress.org/plugins/front-end-only-users/

  2. jayseeCofC
    Member
    Posted 10 months ago #

    Did you by chance try to edit the php code through the admin panel plugins->editor? In wordpress if there's a php error in a file, it won't be able to load your site. The only solution is to ftp in to the server and fix the line of code the error message is displaying (line 37 of Insert_Register_Form.php in your case).

    I ask if you edited the file because I'm using this plugin and haven't had any problems with the register shortcode. Line 37 deals with parsing the attributes passed in when calling the shortcode (ie getting redirect_page from [register redirect_page="somepage.com"]). Hope this info helps!

  3. eznetworks
    Member
    Posted 10 months ago #

    Hello jayseeCofC
    I didn't edit a single php files.
    E

  4. Rustaurius
    Member
    Plugin Author

    Posted 10 months ago #

    Hi EZ,

    Can you let use know what other plugins you're using? There's a small number of users who get a similar error, which I think could be caused by a naming conflict. We're planning on making the variable name less generic than "Message" shortly.

  5. eznetworks
    Member
    Posted 10 months ago #

    I have installed the following plugins.. Front-End Users Plugin, Comprehensive Google Map Plugin and Cleverness To-Do List. After deactivating both plugins 'Comprehensive Google Map Plugin and Cleverness To-Do List' I am capable to Register. Thanks for the suggestion.

    All the best

    E-

  6. Rustaurius
    Member
    Plugin Author

    Posted 9 months ago #

    Hi,

    This should be addressed with the update being released tonight (version 1.12). Please let me know if you're still getting the error after the upgrade is available and installed.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.