WordPress.org

Forums

Front-End Only Users
Registered user with username only (4 posts)

  1. hixmyrick
    Member
    Posted 9 months ago #

    Just installed plugin and tested the plugin. Here are the steps for my error.

    1. Create page and put in shortcode "[register]"
    2. All fields set to required, including first and last name and email
    3. Enter username only
    4. Submit
    5. Where error message should be, only see a "T"
    6. Re-submit form with only username again
    7. Get message 'Your account has been succesfully created.'

    https://wordpress.org/plugins/front-end-only-users/

  2. hixmyrick
    Member
    Posted 9 months ago #

    I have tested more and now seem to be having the same problem as strokahontas describes in this post:

    ... when I try to register a new user it just displays "T" at the top of the registration page and the user is not added to the database.

  3. hixmyrick
    Member
    Posted 9 months ago #

    Okay, more testing. Here are the steps I'm doing. First "blank" user is registered with no information. Subsequent attempts produce "T" error and no additional users are inserted into the database.

    1. Remove all users from database
    2. Close and reopen Firefox, clear all history, cookies, etc.
    3. Navigate to page with "register" short code
    4. Submit blank form
    5. Message: "Your account has been succesfully created."
    6. Immediately submit blank form again
    7. Error: "There is already a user with that Username, please select a different one." This is a correct error because a user was created on the first submission with a blank username.
    8. Navigate away from register page and back for a fresh form
    9. Submit blank form
    10. Error: "There is already a user with that Username, please select a different one."
    11. Enter a username and submit form
    12. "T" error, username remains filled in
    13. Enter password in "Password" field and submit form
    14. Error: "The passwords you entered did not match." Correct error.
    15. Complete "Repeat Password" field and submit form
    16. "T" error, username and pw fields remain filled in
    17. Enter "First Name" and submit form
    18. "T" error, username, pw, and first name fields remain filled in
    19. Enter "Last Name" and submit form
    20. "T" error, username, pw, first name, and last name fields remain filled in
    21. Enter "Email" and submit form
    22. "T" error, all fields remain filled in
    23. Submit form again
    24. "T" error, all fields remain filled in

    Hope this helps figure it out.

  4. Rustaurius
    Member
    Plugin Author

    Posted 8 months ago #

    Thanks for the detailed instructions. We'll follow your procedure and fix this error ASAP. Sorry about the delayed reply to your post.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.