WordPress.org

Forums

MailPress
Registered & Unverified Email yet User is Activated in MailPress by defaut (3 posts)

  1. janubande007
    Member
    Posted 2 years ago #

    I have User Moderation enabled on "Theme-my-login" plugin (http://wordpress.org/extend/plugins/theme-my-login/). I like that I can get my users to verify emails before allowing them access to login. There however is one problem when I'm using this feature on a MailPress activated site.

    In MailPress settings, the users are added as "Activated" so even if the user has not verified their email address, they are now going to be getting Newsletters & Emails from my system that are automatically generated. Ideally they should be added as "Deactivated" and once they have verified their emails, they should change to "Activated" inside MailPress.

    Any suggestions on how to fix this problem? Is this an issue with MailPress or Theme-My-Login, who's at fault here?

    http://wordpress.org/extend/plugins/mailpress/

  2. RENAUT
    Member
    Plugin Author

    Posted 2 years ago #

    when using mailpress subscription form, mp users are created with status 'waiting' till the email is verified.

    i think your "Theme-my-login" plugin is inserting the user as a wp user.
    In MailPress you might be using add-on Sync_wordpress_user which consider all wp users having their email checked !

  3. janubande007
    Member
    Posted 2 years ago #

    Hello Ande Reanut. Thanks for the quick reply.

    I am using the Sync Add-on Option because it does not make sense for me to ask the user to re-enter their Email address for another Add-on after they have verified their email address by clicking a link in the email sent to them after blog user registration. So if you were using a feature like "user moderation" where a new blog user that is registering with your Blog has to verify his email address by clicking a link in the email, before he is considered a blog member....how would you solve this problem when the blog is also MailPress enabled?

    You help is greatly appreciated.

    BTW....when is your Wiki expected to be up & running...I've never visited it since I've installed MailPress a week ago.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic