Support » Plugins » register_http_request_failed … SSL connection timeout

  • I have a couple dozen sites that have been happily running on my server and collecting stats with jetpack 1.1.3, but as of yesterday they all stopped working.

    Jetpack could not contact register_http_request_failed. This usually means something is incorrectly configured on your web host.

    SSL connection timeout

    I’ve made no changes on the server and no updates in WordPress.

    There’s not indication in the logs as to what the issue might be.

    I’m stumped. Anybody got any suggestions?

Viewing 15 replies - 1 through 15 (of 31 total)
  • Same Here !! I’ve been using this plugin for over 6 months and for 2 days I can’t see the stats of my site so I disconnected the plugin and tried to connect it again and got this error as well.

    Ditto here. This same problem has also knocked the older stats plugin offline.

    same here. stats randomly stopped working and when i tried to deactivate and reactivate, it cant’ connect and i keep getting register_http_request_failed error.

    I attempted to load this plugin for the first time a couple days ago and I’m getting the same thing.

    I’m having the same issue. It’s only present with my sites on one host. Site with another host is fine. I’ve tried to remove and reinstall the plugin, use a different API key, etc but nothing works. Leaving the plugin enabled also causes timeouts on things like publishing a post.

    which host are you using? is not working (also called

    host gator

    I think this is systemic (

    I use hostgator. I agree with mokelly. This is on systemic. ugh drives me crazy. Extremely slow time with posting, editing etc. I seriously have been sitting here waiting for my post to submit/load for the last 5 minutes and finally it posted. This has been going on for the last 4 days for me. Any fixes yet?????

    I’ve emailed Automattic about the issue and let them know that a number of people on these support forums are experiencing the problem but haven’t heard back from them. Might be helpful if others contacted their support system to make the issue well known.

    It seems that is just inaccessible from certain IP’s. I’ve worked on it this off and on for the last several days and it seems that the api base address – is just plain inaccessible.

    If I export the site to my local dev server it works fine, but from my production vps at hostgator it won’t connect.

    A simpler test is to just try to open the jetpack page… lynx Again it works fine from my dev server or workstation, but not from my production server.

    I tapped hostgator support and they confirmed the same thing…

    “Thank you for contacting HostGator! I apologize for the inconveniences you’re facing and would be more than happy to point you in the right direction. I was able to replicate your issue. It does not seem that there is a problem with lynx or anything on the server preventing it from connecting. I am able to successfully connect to and other pages using lynx, but am unable to connect to from your server. However, I am able to connect to using lynx from our other servers.”

    I don’t know if my addresses are being blocked, but I have sites on 5 different ip’s on that server and none of them are working.

    I still don’t have an answer, but hopefully that will help someone along.

    i did the exact same thing. lynx’ing to or doesn’t work from my host which is why i am assuming it’s timing out. i’ve worked with my provider to ensure the firewall is not on their side so it’s a WP issue. I’ve submitted a ticket to WP but nothing so far.

    My hosting company ( says that they were able to connect to those two sites. They did offer to move my sites to another server to see if it changes anything. We’ll see if that works.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘register_http_request_failed … SSL connection timeout’ is closed to new replies.