Support » Requests and Feedback » register_globals OFF

  • I have had some problems with parts of WordPress and certain modules on my host, rss feeds not working, stats not working, spam blockers like akimnet and Spam Karma, wp-shoutcast etc and I believe this is the cause……….

    UPDATE 7/6/04

    Following a security upgrade, a change has been made to our PHP configuration to switch register_globals OFF. This basically means that statements such as:

    echo $my_variable_name;

    will no longer function correctly. There is a simple resolution to this problem in the form of some code that should be inserted into the top of your page. Here are some examples:

    If the variable you are trying to access is passed via the URL string:


    If the variable you are trying to access is passed via a form post operation:


    If the variable you are trying to access is a server environment variable:


Viewing 1 replies (of 1 total)
  • This is the second webhost that i use to disable this. On the first webhost alot of things do not work….stats, newsfeeds using rss etc in phpnule no longer work. And in another site using wordpress in the admin the wordpress news fails to show. Will this change that my other webhost is also implementing affect blogcms and pubb?

    “This is to let you know that as from 1 Feb 2006 the setting “register_globals” in php will be disabled.

    This setting has been disabled by default for sometime as it poses security issues in certain php scripts.

    Unfortunately if you site needs the “register_globals” enabled you will need to recode the script.

    If you are using third party scripts, you are advised to get the most recent release, as most well known php scripts have already been recoded to work with the new php default settings.

    We apologise for the inconvenience this may cause you”

Viewing 1 replies (of 1 total)
  • The topic ‘register_globals OFF’ is closed to new replies.