Support » Plugins » Register Plus custom Image Upload Error

  • Resolved srqwebguy

    (@srqwebguy)



    When I try to upload the custom logo in Register Plus I get the following error message:

    ********************************

    Warning: move_uploaded_file(/home/admin/domains/mydomain.com/public_html//home/admin/domains/mydomain.com/public_html/wp-content/uploads/voth-logo-final.jpg) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/admin/domains/mydomain.com/public_html/wp-content/plugins/register-plus/register-plus.php on line 309

    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move ‘/tmp/phpvko6iG’ to ‘/home/admin/domains/mydomain.com/public_html//home/admin/domains/mydomain.com/public_html/wp-content/uploads/voth-logo-final.jpg’ in /home/admin/domains/mydomain.com/public_html/wp-content/plugins/register-plus/register-plus.php on line 309

    **************************************
    The problem appears to be that the path shown is “doubled up”. If you remove the first part, “/home/admin/domains/mydomain.com/public_html/”, the path is correct. Where would I go to fix this path?

    Thanks in advance. Very cool plug in by the way…

Viewing 13 replies - 1 through 13 (of 13 total)
  • It did this for me too, I’m using 2.6, not sure if that is why.

    But I looked at the code, it looks like the path “wp-content/uploads/” might be hardcoded into the plugin for uploading custom logo?

    I noticed that my upload path was set to “wp-content/”, I think this was the 2.6 default. I changed it to “wp-content/uploads/”(no sorting by year/month), and it worked for me.

    Thanks. I’m on 2.6 and my default is “wp-content/uploads/”.

    But I unchecked the sort by year/month (and added the full URL for good measure) and that fixed it.

    Appreciate the help.

    Not sure why it’s doubling up your ABSPATH, the uploading function is not hard-coded at all. It uses your ABSPATH + your upload path you set in the options. I’ve tried using different folders and different options and my logo uploads every time. It must just be a server issue, something strange that messes with the upload path.

    Not sure why it’s doubling up your ABSPATH

    I had thought that they tinkered with this a bit in 2.6, since there were so many problems with the media uploader in 2.5? Or maybe it was just a fluke.

    Great plugin BTW!

    Agreed. It does a great job. Thanks!

    I have a problem as well. WP 2.6

    default uploads folder:
    wp-content/uploads

    But when I try to upload a custom logo, nothing happens…

    Any ideas?

    I’m having the same issues as jossi and srqwebguy.

    jossi/adam, did you try unchecking the sort by year/month?

    You could try adding the full URL, as srqwebguy mentioned that he did.

    And of course, you should already have an uploads directory with the proper permissions…

    Yes that did it.

    First I unchecked the sort year/month, then I uploaded the logo and then checked again the sort year/month, which I need.

    All seems to work now

    I was able to successfully upload the image but afterwords it doesn’t show up anymore until I upload the logo again.

    guys, help, when i upload my logo it say

    Warning: copy(/home/skilrcom/public_html/styles/clipbucketblue/images/logo.gif) [function.copy]: failed to open stream: Permission denied in /home/skilrcom/public_html/includes/classes/mysql_queries.class.php on line 983

    Warning: imagegif() [function.imagegif]: Unable to open ‘/home/skilrcom/public_html/styles/clipbucketblue/images/logo.gif’ for writing: Permission denied in /home/skilrcom/public_html/includes/classes/image.class.php on line 35

    What happened? appreciate your help very much. Thanks!@

    Make sure your uploads path under miscellaneous.

    so wp-content/uploads

    then make sure you have the correct permissions on your upload folder. That will fix it.

    chmod 777 or 755 might do it.

    i did it with a manual upload via-ftp to wp-content/uploads

    ciao!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Register Plus custom Image Upload Error’ is closed to new replies.