Support » Plugins and Hacks » [Plugin: Register Plus] – can’t be activated in WP 2.5.1

[Plugin: Register Plus] – can’t be activated in WP 2.5.1

  • After updating WP to 2.5.1. the Register PLus Plugin can’t be activaed at all.
    Trying to activate gives this error message:
    “Parse error: syntax error, unexpected $end in C:\……..\wordpress\wp-content\plugins\register-plus\register-plus.php on line 874”
    The error message is coming even after updating Register Plus to version 2.1

Viewing 15 replies - 1 through 15 (of 20 total)
  • You may want to try deleting the plugin and reinstalling it. There is nothing on line 874 to cause an error – it’s blank!

    I’ve tested the plugin and it seems to activate fine on WP 2.5.1.
    Let me know what happens after you remove and reinstall the plugin.


    Here is the result after deleting the plugin and reinstalling it – and restarting the server as well. To be sure I downloaded a new Rgister Plus for the reinstallation.
    Be it won’t activate, and produced the same error message as earlier, except for the line number which was 873 this time . . .

    Sorry, but I can’t recreate your error. I’ve tried it locally on my windows machine and on my live site and it activates without any errors. Could be you have another plugin causing a conflict? Try deactivating your other plugins before activating this one and see what happens. Let me know.

    Yes, I’ve just deactivated all plugins, restarted the server and tried to activate Register Plus. But the wellknown error message pops up, but this time the error line number is 877.
    It looks like to me as “it” is looking for something more, but what?
    The error message says “…syntax error, unexpected $end in…..”.
    I’ve tried to put an empty line in the file, and then the error message tells that the error is in line 878 – and with two new lines the error message is line 879. (allways the first empty line at the end – saying “..unexpected $end…”
    I don’t know what more to do to get it “up and go”…?

    Exactly the same issue as eno.

    Parse error: syntax error, unexpected $end in C:\wamp\www\wp1\wp-content\plugins\register-plus\register-plus.php on line 877 On a fresh local install of 2.51

    Hoping for fix?


    pleAseNote: the plugin DOES work with my online test site using php v 5 Local version is 5.25 Hope that helps

    And, I’m using PHP version 5.25, too. . .

    And, I’m using PHP version 5.25, too. . .

    Parse error: syntax error, unexpected $end in register-plus.php on line 877


    register-plus.php 725!!!!!!!!!


    Thanks guys, it’s been a busy week and I’ve been sick too, so I haven’t had any time to update, I’ll get to it this weekend though. Cheers!

    Hi all,

    In the last version of the plugin (2.2), replace “<?” by “<?php” in line 725 of the file register-plus.php. The short_open_tag is not activated in most PHP installation so the open tag “<?” is not understand by PHP it-self.

    David Duret


    and thanks a lot!!

    Now I got Register Plus activated, but the “Validation” doesn’t work. . .?!
    Every time I give it a try, the answer is “ERROR: Image Validation does not match”.
    But I am quite sure I entered the text from the image without errors….!



    Same problem for me but not find what happened at this moment 🙁

    I have WinXP, PHP 5.2.5 and Apache 1.3.x


    And I use: WinXP, PHP 5.2.5, Apache 2.2.6


    Same problem with the validation code. But i found if u have the quick-shop plugin actived the validation code works……but don’t ask me why 😉


Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Plugin: Register Plus] – can’t be activated in WP 2.5.1’ is closed to new replies.