Support » Plugin: Woo Shipping for Nova Poshta » Region Field do not working

  • Resolved viter-z-bayraku

    (@viter-z-bayraku)


    After adding API key and typing region as Kyiv or Kyivska or Київ or Київська plugin do not giving any result. Thank You for fixing.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Additional info:

    [Wed Oct 05 15:23:56.933904 2016] [:error] [pid 19154] \xd0\x9f\xd0\xbe\xd0\xbc\xd0\xb8\xd0\xbb\xd0\xba\xd0\xb0 \xd0\x91\xd0\x94 WordPress Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8mb4_unicode_520_ci,COERCIBLE) for operation 'like' \xd0\xb4\xd0\xbb\xd1\x8f \xd0\xb7\xd0\xb0\xd0\xbf\xd0\xb8\xd1\x82\xd1\x83 SELECT * FROM wp_nova_poshta_area WHERE (descriptionLIKE CONCAT('%', '\xd0\x9a\xd0\xb8', '%') ORdescription_ruLIKE CONCAT('%', '\xd0\x9a\xd0\xb8', '%')) AND (area_type='nova_poshta_region') \r\n AND (parent_area_refIS NULL) \xd1\x81\xd0\xbf\xd1\x80\xd0\xb8\xd1\x87\xd0\xb8\xd0\xbd\xd0\xb5\xd0\xbd\xd0\xb0 require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), plugins\\NovaPoshta\\classes\\AjaxRoute::init, plugins\\NovaPoshta\\classes\\AjaxRoute->handleRequest, do_action('wp_ajax_get_regions_by_name_suggestion'), plugins\\NovaPoshta\\classes\\Area::ajaxGetAreasByNameSuggestion, plugins\\NovaPoshta\\classes\\Area::findByNameSuggestionAndParentArea, plugins\\NovaPoshta\\classes\\Area::findByQuery, referer: http://rukotvory.com.ua/wp-admin/admin.php?page=wc-settings&tab=shipping&section=nova_poshta_shipping_method

    UPDATE: Problem with encoding has been fixed. Plugin are reinstalled. But still region selection do not working and database of plugin is empty.

    Plugin Author sergeynezbritskiy

    (@snezbritskiy)

    Hi! Thank you for you report!
    First, could you check log file {plugin-dir}/logs/updates.log. Here you can find what really happened. You also can try temporary edit this method \plugins\NovaPoshta\classes\DatabaseSync::getInterval, at the very beginning of this method just put “return 1” which means update database with 1 second interval.
    Please, let me know the results and feel free to contact with me!

    Plugin Author sergeynezbritskiy

    (@snezbritskiy)

    Hi! I’ve reproduced the issue and fixed it. Please review version 1.2.1 of plugin.
    Thanks for you report!

    Thank You. Plugin is working. But please remove plugin data in wp_options database when user are deleting the plugin. Because if you do not do it, plugin still does not work.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Region Field do not working’ is closed to new replies.