Support » Plugin: Regenerate Thumbnails » Regenerate Thumbnails: Error getting a chunk of thumbnail IDs to process.

  • Resolved Laura Ionescu

    (@laurawpheroes)


    Hello!
    I tried to regenerate my thumbnails but I got an error and I have to admit that I have absolutely no idea how to solve it. I was hoping you might know how to help 🙂
    Here is the console:

    http://chroniclesofher.com/wp-json/wp/v2/media/?page=1&per_page=25&_fields=id&is_regeneratable=1&exclude_site_icons=1&orderby=id&order=asc

    Regenerate Thumbnails: Error getting a chunk of thumbnail IDs to process.
    {readyState: 4, getResponseHeader: ƒ, getAllResponseHeaders: ƒ, setRequestHeader: ƒ, overrideMimeType: ƒ, …}abort: ƒ (a)always: ƒ ()arguments: nullcaller: nulllength: 0name: “always”prototype: {constructor: ƒ}__proto__: ƒ ()FunctionLocation: load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2Scopes: Scopes[3]complete: ƒ ()done: ƒ ()error: ƒ ()fail: ƒ ()getAllResponseHeaders: ƒ ()getResponseHeader: ƒ (a)overrideMimeType: ƒ (a)pipe: ƒ ()progress: ƒ ()promise: ƒ (a)readyState: 4responseJSON: [{…}]responseText: “[{“code”:”json_cookie_invalid_nonce”,”message”:”Cookie nonce is invalid”}]”setRequestHeader: ƒ (a,b)state: ƒ ()status: 403statusCode: ƒ (a)statusText: “Forbidden”success: ƒ ()then: ƒ ()__proto__: Object error Forbidden

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Alex Mills

    (@viper007bond)

    It looks like you might have the old “WP REST API” plugin enabled. This plugin is no longer needed (and is actually outdated) now that the REST API is a part of WordPress itself.

    Disable and delete that plugin and then things should work as expected.

    eaglejohn

    (@danielbenjamins)

    I have the same problem but I don’t have any version of WP REST API running…

    My WordPress Address is set up differently from my Site Address: https://mywebsite.com/wp/ vs https://mywebsite.com.

    There’s no errors when I set both to https://mywebsite.com/wp/

    But that’s not really a solution since I don’t want “/wp” in my website URL…

    • This reply was modified 1 year, 10 months ago by eaglejohn.
    Plugin Contributor Alex Mills

    (@viper007bond)

    @danielbenjamins: Can you make a separate thread please? I don’t want to pollute this thread with a separate issue. Thanks. 🙂

    For those who find this via Google Search, first deactivate “WP REST API” if active.

    Then deactivate “Yoast SEO,” and reactivate it.

    (Yoast plus outdated REST equals corrupted cookie or something. Reactivating clears it up.)

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Regenerate Thumbnails: Error getting a chunk of thumbnail IDs to process.’ is closed to new replies.