Support » Plugin: WebP Converter for Media - Convert WebP & Optimize Images » Regenerate images not working

  • Resolved b8engl

    (@b8engl)


    The regenerate images does not work in my case! I have defined a new image folder with define( 'UPLOADS', 'wp-content/'.'imagens' ); in wp-config, is this why it doesn’t work?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter b8engl

    (@b8engl)

    The issue was the endpoint wp-content! Is there anyway to set this with a custom path?

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @b8engl,

    Thank you for your message. I added a new update to the plugin in connection with your request. Please download version 1.0.7.

    In the plugin FAQ I also added the question How to change path to uploads?. Everything is explained there.

    Will this solve your problem?

    Thread Starter b8engl

    (@b8engl)

    @mateuszgbiorczyk

    I tested the filter with my custom endpoint, but unfortunately still showing the same error while generating. Don’t know if the modules are active or not on the server. Maybe a fail check in future release…
    Thanks anyway!

    • This reply was modified 1 year, 11 months ago by b8engl.
    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @b8engl, tell me what are your errors?

    What code added with filters?

    Thread Starter b8engl

    (@b8engl)

    <div class="webpLoader__errorsContentList">File "/var/www/vhosts/webpage.pt/httpdocs/conteudo/imagens/apple-iphone-7-rose-gold-grade-b-4.png" does not exist.<br>

    add_filter('webpc_uploads_path', function($path) {
      return 'conteudo/webp';
    });
    Thread Starter b8engl

    (@b8engl)

    Also the settings doesn’t stick on first saving, always on second try. Who knows why…

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Why did you use only one filter? Please read exactly what is written there.

    You have set the file path as: conteudo/webp. In the first post you wrote that you have set wp-content/imagens.

    Please try this code:

    add_filter('webpc_uploads_path', function($path) {
      return 'wp-content/imagens';
    });
    add_filter('webpc_uploads_webp', function($path) {
      return 'wp-content/imagens-webpc';
    });
    Thread Starter b8engl

    (@b8engl)

    Q: What’s the difference between webpc_uploads_path and webpc_uploads_webp?
    A: one is original and the other is your path!

    So i just need to change one path cause the other one will be created, yes?

    Tryed with my custom endpoint conteudo = wp-content (same resulte!)
    Tryed with default path = wp-content (same resulte!)
    Tryed with both filters and create the folder = imagens-webpc (same resulte!)

    Thread Starter b8engl

    (@b8engl)

    Does this plugin checks for active extensions on server side?

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Your issue is the wrong path to files from uploads. The message is clear and clear.

    Can you provide the URL of your page?

    Thread Starter b8engl

    (@b8engl)

    The error message is the same without gd or imagick modules active!

    • This reply was modified 1 year, 11 months ago by b8engl.
    Thread Starter b8engl

    (@b8engl)

    Why after deactivating plugin code remain in htaccess?

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    “The error message is the same without gd or imagick modules active!” – what does it mean?

    I would like to help you, but please try to explain everything to me. I do not have access to your website, to your code.

    To delete the contents of the .htaccess file please go to Settings -> Permalinks -> WebP Converter in the administration panel. And then click save changes. The code from the .htaccess file will disappear.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Regenerate images not working’ is closed to new replies.